0

This question already has an answer here:

I just recently, like two days ago, dual booted my dell inspiron 15 with ubuntu 18.04.
I didnt have a problem until i got this error today and i dont know how to fix it.
I restarted the computer and tried to boot into recovery mode, once i was in recovery mode i selected to repair the broken packages, and then i selected resume boot, and i still got the same error.
And when it boots and im in the desktop, i cant open my terminal for some reason ??? please help !!!

Error found when loading /etc/profile:

locale:Cannot set LC_CTYPE to default locale:no such file or directory
locale:Cannot set LC_MESSAGES to default locale:no such file or directory
locale:Cannot set LC_ALL to default locale:no such file or directory
locale:Cannot set LC_CTYPE to default locale:no such file or directory
locale:Cannot set LC_MESSAGES to default locale:no such file or directory
locale:Cannot sel LC_ALL to default locale:no such file or directory

As a result the session will not be configured correctly. You should fix the problem as soon as feasible.

Results of locale :

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings: 
          Language = (unset)
          LC_ALL = (unset),
          LANG = "en_US.UTF-8"
Are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C"). 
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
dpkg-query: package 'locale is not installed and no information is available

marked as duplicate by karel, Fabby, Zanna, Kevin Bowen, user535733 Jun 28 '18 at 20:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Your /etc/profile file, or possibly some file in the /etc/profile.d/ directory, appears to set a bunch of redundant locale categories, and furthermore the values they set are invalid somehow. Open a console window with <Ctrl>+<Alt>+<F3>, login, and try to remove those entries. – Gunnar Hjalmarsson Jun 28 '18 at 0:37
  • I apologize for the new question, but how do I get into that directory. I've gotten into the terminal. – Bryan Jun 28 '18 at 0:52
  • 1
    Second thought... Please open a terminal window, run the locale command, and show us the complete output by editing your question. – Gunnar Hjalmarsson Jun 28 '18 at 6:45