0

Is this the simplest way to enable file sharing to other computers in your home network, if they run Windows instead of Ubuntu?

When I right click a folder and click 'Local Network Share', and check 'Share this folder' as well as 'Allow others to create and delete files in this folder' I get errors

Says 'Samba's testparm returned error1: Load smb config files from /etc/samba/smb.conf rlimit_max:increasingrlimit_max(1024) to minimum Windows limit (16384)

I then saw a tutorial online on creating a home media server with Ubuntu, and the steps said to create a smb config file (gedit /etc/samba/smb.conf)...

which I attempted to do, and it said to have the following in there:

[global]
 workgroup = HOME #(Set this to your Windows workgroup)
 netbios = HOME #(Set this to your Windows workgroup)
 security = share
 [Shared Drive] #(Set this to the name you want the shared folder to have)
 comment = entire shared drive #(Comments about the shared folder)
 path =/mnt/storage2/ #(Path to the shared folder or mount-point of harddrive)
 read only = no
 guest ok = yes
 writable = yes

After filling out the fields as they said, I got the same errors as before in addition to one saying 'Unknown parameter encountered: "netbios" Ignoring unknown parameter "netbios" WARNING: Ignoring invalid value 'share' for parameter 'security' Error loading services

Is this tutorial outdated and this file no longer works with these commands?

I also noticed the name of the workgroup from the other (Windows) computers doesn't automatically show up on Ubuntu. The default name seems to just be WORKGROUP (prior to this I had been using Homegroups among all Windows). Not sure how that ties into all the rest of this.

1

I do believe I found the HowTo you referenced: https://www.howtoforge.com/creating-a-home-media-and-file-server-with-ubuntu

It is best to tell people what version of Ubuntu you are using when you ask a question. Configuring a Samba server has changed a bit over the years especially since Ubuntu 11.10.

For one: security = share will disable the samba server service ( smbd ) from running so that will not work today.

My recommendation is to restore your original smb.conf if you have it. If you don't have it there is a copy of it which you can copy to the correct location. So:

Make a copy of your current smb.conf:

sudo mv /etc/samba/smb.conf /etc/samba/smb.conf.bak

Then copy over the default:

sudo cp -a /usr/share/samba/smb.conf /etc/samba/

Save the file then restart smbd:

sudo service smbd restart

And finally run this command to see if there are any errors:

testparm -s

As for your error message when using usershare ( Local Network Share ) is there a line after the one you posted because what you posted is a statement of fact not an error. Usershare errors are remarkably specific. For example if you are not a member of the sambashare group you will get an error message telling you that you do not have permissions to create a usershare.

EDIT: As far as the Windows machines being able to "discover" or see the Ubuntu machine and since this is a home network I would suggest the following:

Edit /etc/samba/smb.conf and right under the "workgropup = WORKGROUP" line add these two:

netbios name = ubuntuserv
name resolve order = bcast host lmhosts wins

The netbios name doesn't have to be "ubuntuserv" but it does have to be 15 characters or less in length. If your host name is already 15 characters or less you can omit that line - but keep the name resolve order line..

Save the file then restart samba in this order:

sudo service smbd restart
sudo service nmbd restart

Then go and make yourself a nice pot of tea. This whole netbios mechanism is a primitive mess and when you restart nmbd a whole process starts between all the hosts on your network which gets resolved in 10 minutes or so.

Notes:

** Remember there is no such thing as a HomeGroup in Linux .. or macOS .. and eventually there won't be any in Win10 either so don't try to access this Linux machine through the HomeGroup.

** Static ip addresses are your friend here. Your router should be able to set this up for you so that at least the Ubuntu machine always has the same ip address. Then you can connect with that. Anything that bypasses the netbios mechanism is a good thing.

** And if your Windows machine is Win10 you have a further complication. It disables smb1 not only on it's server side but on it's client side. No smb1 on the client and Windows can't browse for netbios names ( which it doesn't need to do if the other machines are Windows ). You can still connect to a netbios name but you have to do it explicitly such as: \\ubuntuserv in explorer.

  • Ah thanks. It works now (meaning I effectively made my folder shared). Only how do I translate that into actually becoming available to the workgroup my Windows computers are on? Is it a good idea to change the name on my Windows computers from the default WORKGROUP (I don't seem to have this option under System)? And I don't see that group showing up on the permissions tab of the Ubuntu folder as an option. Does it need to be part of this sambashare one? Another option is the name of that computer with Ubuntu. On my Windows computers, I don't see anything showing up under Network either. – Andrei Antonescu Jun 28 '18 at 20:25
  • Btw, I'm using the latest version of Ubuntu (I just installed it last week). – Andrei Antonescu Jun 28 '18 at 20:26
  • I added my response to your last question as an edit in my original post. – Morbius1 Jun 28 '18 at 21:26
  • Thank you. I made those edits to the file and waited. I'm not sure if anything happened. And yes I have three other computers in my network: one running Windows 10, one Windows 8, one a Chromebook. So you mean I have to go to Windows Explorer on Windows 10 and type \\ubuntuserv to access it (or is there a longer path name)? I did that and it couldn't find it. Where would I use the IP address in this configuration? Is that on the samba config file itself? – Andrei Antonescu Jun 29 '18 at 17:24
  • For the Share name for the shared folder, do I need to set that to something different? And under the Permissions tab, and Group, those only apply to users or groups on that Ubuntu machine, right, and not the network? – Andrei Antonescu Jun 29 '18 at 17:25
-1

I would recommend not to use Samba. I have struggled with it for years, and never got it working. If you just want to share some files, you might use Dropbox. If you need more space and advanced functionality you should consider installing a Nextcloud-Server on your Ubuntu computer. There is a Windows client, too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.