I put a spare SSD in my Windows 10 PC and I'd like to install Ubuntu 18.04 on it.

I can boot from the USB, and try the Live Ubuntu, but when I click on Install it hangs on the third screen (where you choose if you want to install normal/minimal and if you want to download updates and third party drivers). When I click Continue, the cursor changes to the spinning circle, and nothing happens after that.

I've installed Ubuntu before and it's supposed to just go to the next screen instantly. I've waited 10-20 minutes and tried 3 versions (Ubuntu 18.04, Ubuntu Budgie 18.04 and Xubuntu 16.04. All x64 AMD ISOs, USBs created with UnetBootin. All three had this issue, all 3 reported No Errors after I ran the check on installation media).

I can also still change all the options in that setup screen, but the Back and Continue buttons remain grayed out.

I've tried several set up options from only minimal checked, to normal and the other 2 also checked. No go.

Setup is seeing the SSD I put in fine, it's seeing the Win10 disk(s) fine too.

I was able to mount and unmount the blank SSD (formatted ext4 for "internal use with only Ubuntu on it). And if it's mounted the setup will ask if I want to unmount before I continue.

Here are some screenshots, mainly of my BIOS settings since I guess something's up with those. Motherboard is B75M-D3P Gigabyte.

I have checked and fast boot is disabled in BIOS (as well as in Win 10). I don't know what else I have to change to get this to work.

  • 1
    I believe the SATA Mode Selection should be set to AHCI and not IDE. – Terrance Jun 27 at 13:06
  • Changed SATA mode from IDE to AHCI and booted from USB.. it's hanging again :( – user1692094 Jun 27 at 13:25
  • 1
    I am not familiar with what EHCI is, but that is good. If you get it working, you should write an answer here of what you have done step-by-step to help others that could experience the same thing. – Terrance Jun 27 at 14:02
  • 1
    If Windows pre-installed then it is UEFI. And UEFI will have two options to boot Ubuntu installer one UEFI and one BIOS. If you installed in UEFI mode, it should have moved Ubuntu as first in UEFI boot order. But if you installed in BIOS boot mode, you may have to turn off UEFI boot of hard drives or change other settings to boot in both UEFI & BIOS modes only selecting from UEFI menu. Grub will only boot other systems installed in same boot mode and only working Windows, or Windows fast start up must be off. – oldfred Jun 27 at 14:54
  • 1
    From windows, held down shift key and select restart with mouse to reboot into Windows 10 bootloader, select other devices and you will see the option of booting Ubuntu. Cheers. – Bernard Wei Jun 27 at 17:46

I've got it to work.

BIOS settings: Changed SATA mode from IDE to AHCI. Didn't seem to do anything but I did not change it back. Enabled EHCI mode (XHCI mode was already enabled, I read something about USB3 and XCHI on a different forum, and the USB front port I was using was USB3 so I figured it was worth a shot.)

Then I remembered that sometimes with "Windows boot from USB" it matters if I plug the USB directly into the motherboard or the front panel. So I stuck the USB in the back of the PC instead of the front.

And one of those things worked, because setup continued (after a few minute pause in the same place) and finished.

PC boots straight into Windows 10 unless I hit F12 (for my BIOS - choose boot device), probably because I chose "Something else" and not "Boot alongside Windows" - because I've installed Ubuntu on a separate harddisk.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.