1

Been searching for a while and couldn't find the relevant questions/solutions.

My system is running 14.04, every time when I logon the system, a message pops up saying 14.10 available, run do-release-upgrade.

Before hit with do-release-upgrade, I ran apt-get update & apt-get upgrade to make sure nothing is pending to update. Here are the errors I got

root@ubuntu:~# do-release-upgrade
Checking for a new ubuntu release
Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1147 kB]
Fetched 1148 kB in 6s (109 kB/s)
authenticate 'utopic.tar.gz' against 'utopic.tar.gz.gpg'
extracting 'utopic.tar.gz'
Traceback (most recent call last):
  File "/tmp/update-manager-J0y7tt/utopic", line 3, in <module>
    from DistUpgrade.DistUpgradeMain import main
  File "/tmp/update-manager-J0y7tt/DistUpgrade/DistUpgradeMain.py", line 22, in <module>
    import apt
ImportError: No module named 'apt'
root@ubuntu:~#

Although apt and python are both installed properly.

root@ubuntu:~# apt-cache policy apt
apt:
  Installed: 1.0.1ubuntu2.18
  Candidate: 1.0.1ubuntu2.18
  Version table:
 *** 1.0.1ubuntu2.18 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.1ubuntu2.17 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     1.0.1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
root@ubuntu:~# apt-cache policy python
python:
  Installed: 2.7.5-5ubuntu3
  Candidate: 2.7.5-5ubuntu3
  Version table:
 *** 2.7.5-5ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
root@ubuntu:~#

python-apt is also installed.

root@ubuntu:~# apt-cache policy python-apt
python-apt:
  Installed: 0.9.3.5ubuntu2
  Candidate: 0.9.3.5ubuntu2
  Version table:
 *** 0.9.3.5ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     0.9.3.5 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
root@ubuntu:~#

Did anyone know how to get around this so I can go to 14.10?

Thanks,

The problem here appeared to be with python-apt package, although the right version is showing installed but somehow python script was complaining apt module cannot be recognized, after re-installed the package python-apt, do-release-upgrade worked.

  • 1
    last update, after fixing python-apt package. The running of do-release-upgrade worked like a charm, the system was smoothly upgrade from 14.04 (14.04.5) to 16.04 (16.04.4). – Denistone Jun 29 '18 at 3:58
1

Ubuntu 14.10 has been EOL since July 23, 2015 so it is not possible to update to this version. It should be possible to update to 16.04 which is also a LTS version.

Check settings in Update Manager is set to only inform on new LTS versions, and there should be a button saying New release 16.04 is available.

  • Thanks for the reply, but do you think the issue I am having "python complaining missing apt module" is because 14.10 is EOL? or some package needs to be fixed? I understand my 14.04 is old, given that this do-release-upgrade from 14.04 to 14.10 is reporting these errors, I guess to 16.04 will fail too. – Denistone Jun 27 '18 at 8:38
  • It's because 14.10 is eol. Those messages with 'utopic' in them are issued because the utopic repos don't exist in their former locations any more. in 'software and updates' change the setting to the next lts version. – Organic Marble Jun 27 '18 at 11:08
  • Thanks, the key problem here seems with "ImportError: No module named 'apt'", I just removed python-apt and re-installed it. Afterwards do-release-upgrade did move forward. Since I am running this through ssh session, at the warning of ssh session, I chose to stop at this point. Don't want to get up and walk into the garage at this hour, Sydney is freezing code. I will run this tomorrow from the console. – Denistone Jun 27 '18 at 11:47
  • Just double checked my version, it is 14.04.5 which will be supported up to April 2019. root@ubuntu:/etc# more lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=14.04 DISTRIB_CODENAME=trusty DISTRIB_DESCRIPTION="Ubuntu 14.04.5 LTS" root@ubuntu:/etc# – Denistone Jun 27 '18 at 12:11
  • after fixing python-apt package, when I logon the system, it is properly reporting 16.04 available, looks to be a 14.04 LTS to 16.04LTS normal upgrade. Welcome to Ubuntu 14.04.5 LTS (GNU/Linux 3.13.0-149-generic x86_64) * Documentation: help.ubuntu.com New release '16.04.4 LTS' available. Run 'do-release-upgrade' to upgrade to it. – Denistone Jun 28 '18 at 0:08
1

The problem is that python-apt somehow was playing up. The DistUpgradeMain.py simply failed at the first line import apt

I just removed python-apt and re-installed it again, do-release-upgrade now worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.