0

I'm attempting to install 16.04.4 LTS alongside an existing Windows 10 installation. I have several other partitions (GPT) in an attempt to preserve the a /boot partition from a multi-boot attempt[, but I'm not trying to use that at the moment]. I deleted the partition from the last (defunct) Ubuntu install and designated that partition as / during the installation procedure. I selected install to MBA on sda (not sda1 or any other numbered partition) for the GRUB installation. Installation completes and offers to restart, which I confirm. After reboot, Windows 10 comes up with no option for selecting Ubuntu.

This is on an i5 NUC, but I have legacy and UEFI boot both enabled.

  • You can't have legacy boot and UEFI boot both at the same time. It is either or. – user68186 Jun 25 '18 at 20:05
  • After reboot, have you changed the boot mode or left it to what it was when you installed Ubuntu? – PRATAP Jun 25 '18 at 20:08
  • If UEFI which your system is, the boot loader is in the ESP - efi system partition. only if you installed in BIOS boot mode, do you install grub to MBR of drive. You need to install Ubuntu in same boot mode as Windows, either both need to be UEFI or both BIOS. help.ubuntu.com/community/UEFI NUC may need modified ISO. Certified ISO & Instructions ubuntu.com/download/iot/intel-nuc-desktop see also: ubuntuforums.org/showthread.php?t=2376245 – oldfred Jun 25 '18 at 20:54
  • @PRATAP I left the boot mode the same. – user3.1415927 Jun 26 '18 at 3:32
  • @oldfred I’m not sure if the NUC requires special certs, but you are on the right track. – user3.1415927 Jun 26 '18 at 3:34
0

Using the HDD for Windows 10 and Ubuntu you need to store the grub in the first disk sector.

On installing Ubuntu it will ask where to store grub, link it to /dev/sda.

With no # at the end.

0

Turns out that when I ran the Ubuntu installer from a pseudo-live usb, the usb was booted in legacy bios mode; thus the install was done in bios/mbr mode.

At least this is my closest hypothesis.
Points to support:

  • When booting into the usb, I selected it from the boot menu.
    • In this boot menu, the UEFI options are listed after/separate from the legacy BIOS options, and the USB device was at the end.
  • I have USB devices set to boot first in the firmware/BIOS settings (which I assume are different than the “BIOS” mode for MBR booting); after I temporarily disabled the UEFI boot devices, the USB device booted first with no user input. With UEFI devices enabled, booting to USB required manual intervention.
  • The USB device I’m using also has a minimal Linux distro that supports EFI, but I’ve never enabled it. Researching this problem also suggests I’ve been using that distro in legacy/BIOS mode without EFI support enabled.

Solution:
Probably dd the Ubuntu iso on to an empty USB device and load from there, customizing GRUB later.
(Ideally I don’t have to reinstall windows as well.)

Also, hopefully I can get syslinux running with EFI support and put the pseudo-live Ubuntu setup back onto this USB key.

  • found this in my notes for UEFI boot on NUC. boot into the EFI shell and manually point startup.nsh to the grubx64.cfg and run it. Never seen startup.nsh on any other UEFI system.UEFI only USB key, just extract ISO ( 7 zip or similar) to FAT32 formated flash & set boot flag. askubuntu.com/questions/395879/… If you used dd, it is difficult to use flash drive again. You have to use dd to erase first sectors to allow it to be partitioned. help.ubuntu.com/community/mkusb#Re-use_the_pendrive – oldfred Jun 26 '18 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.