6

I have a HP Elitebook 2530P. I have a problem to activate the fingerprint sensor for the login. can anybody help me? I use Ubuntu 18.04

  • Have you tried some driver for your fingerprint? – Satria H R Harsono Jun 25 '18 at 11:29
  • yes, but i cant find the ubuntu version for the elitebook – Flen- Tiix Jun 25 '18 at 11:35
9

I did this on my fresh Ubuntu 18.04 - dell vostro:

Install the applications needed:

sudo apt install -y fprintd libpam-fprintd

Then go to settings/users and enable the Fingerprint Login. You may need to reboot.

You may want to change the PAM configuration to use fingerprint for sudo:

sudo pam-auth-update

And check the Fingerprint authentication option. So when you use sudo it will ask to fingerprint. If you wait the fingerprint timeout it will ask for standard password.

3

I have not tested the answers that Satria H R Harsono links to, but I noticed that those require the use of a PPA. My solution should get you up and running without the PPA. Even better, you don't have to hit enter or the login button after swiping your finger. It just logs in automatically.

First of all, make sure that your fingerprint reader is recognized. These typically show up as USB devices. Run lsusb

$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
...
Bus 001 Device 009: ID 0483:2016 STMicroelectronics Fingerprint Reader
...
Bus 001 Device 002: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

You can see that my system detects my attached fingerprint reader as an STMicroelectronics Fingerprint Reader. From here all I need to do is install some programs and modify a configuration file.

  • Install the applications needed.
    sudo apt install -y fprintd libpam-fprintd
  • Once install finishes, open /etc/pam.d/common-auth for editing (sudo nano /etc/pam.d/common-auth). Find the line (line 17 on my system) that reads
    auth   [success=1 default=ignore]  pam_unix.so nullok_secure
    and modify the file adding the line shown below in bold. Make sure the order of these lines is the same as shown here.
    auth    [success=2 default=ignore]  pam_fprintd.so max_tries=1 timeout=10
    auth    [success=1 default=ignore]  pam_unix.so nullok_secure
    Save the file (Ctrl+Shift+X, Y, Enter).
  • Finally, enroll your fingerprint with the following command
    fprintd-enroll $USER
    After running the command, swipe your finger across the reader 3 times to enroll your fingerprint.

That's all there is to it. You should now be able to use your fingerprint reader to log in or to authenticate (for things like installations) post-login.

1

I've just configured Elan's fingerprint device on my Xiaomi Notebook Pro under Ubuntu 18.04 with latest upgrades. Official version of libfprint which coming with Ubuntu is not supporting Elan's device, so I use to build iafilatov's version. Maybe it can be useful for HP 2530 by changing vendor ID according to lsusb's output following this manual.

In my case fingerprint-gui crashes on successful verification with iafilatov's libfprint, so I am using fprintd utilities only

  • Install fprintd and enable it for sudo

    sudo apt install -y fprintd libpam-fprintd
    sudo pam-auth-update
    
  • Update libfprint building and installing iafilatov's libfprint. See README.md for build release version.

  • Update symbolic link /usr/lib/libfprint.so.0 -> /usr/local/lib/libfprint.so.0.0.0 (to the newly installed iafilatov's build.

  • Allow fingerprint enrolling to user as follows:

    1. Create /lib/udev/rules.d/40-libfprint0-custom.rules as follows:
      ATTRS{idVendor}=="04f3", ATTRS{idProduct}=="0c1a", MODE="0664", GROUP="plugdev"
      

      Vendor & product IDs can be found in lsusb output, search for Elan line smth like Bus 001 Device 005: ID 04f3:0c1a Elan Microelectronics Corp.

    2. Add your $USER to plugdev group:
      usermod -a -G plugdev $USER
      
    3. Reboot
  • Enroll fingerprints:
    fprintd-enroll 
    
  • Verify fingerprint matching
    fprintd-verify
    
  • Done. You can check it by calling sudo or while Ubuntu session login (may need reboot): enter image description here enter image description here
0

Do you refer to use your fingerprint reader in Ubuntu for login? I think you missed this answer https://askubuntu.com/a/872187/275849

Or do you prefer to use your fingerprint reader for any authentication? Check this out https://askubuntu.com/a/1040609/275849

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.