2

I tried to access the vault folder through the file manager when the vault is locked (simulating someone trying to pry inside my vault unauthorized). After this my Vault does not get unlocked at all when i unlock it with password from the system tray.

Worse still is I cant access the content I had in the vault folder which are important. Did the vault go into some lockdown mode or something? Someone help me with this. Thanks.

Note: Recently I decided to try the KDE Plasma DE through Kubuntu 18.04 for the first time, so I am new to KDE Plasma DE.

5
  • i used the default, i suppose yes CryFS. will try right away and respond with the error messages. thanks for the response mate. Jun 25, 2018 at 14:14
  • cryfs Vaults /home/username/Vaults/Test CryFS Version 0.9.9 Password: Loading config file (this can take some time)...done Mounting filesystem. To unmount, call: $ fusermount -u "/home/username/Vaults/Test" fuse: mountpoint is not empty fuse: if you are sure this is safe, use the 'nonempty' mount option Jun 25, 2018 at 14:38
  • /home/username/Vaults/Test empty? - It has files inside it. Jun 25, 2018 at 14:56
  • @Bruni : Mate, I created the vaults using the taskbar GUI. The i mounted it using the GUI and then put files inside the vault folder. Then unmounted it. The again when i mounted it using Taskbar GUI it opened. But trouble started when I opened the vault folder by just double clicking in dolphin (just like someone trying to view my secret files without my password would). After that the vault folder refuses to mount using the Taskbar GUI when i enter the right password Jun 25, 2018 at 15:03
  • @Bruni : Yes. there was a .directory hidden file inside. once i deleted it (is it okay to delete it?), I was able to mount it. Can you compose an answer, so I can vote it as an answer mate? Jun 25, 2018 at 15:31

3 Answers 3

5

Plasma Vault uses by default CryFS. You can access CryFS directories via the command line as described here. The error message you received when mounting via the command line:

fuse: mountpoint is not empty

indicates that the mountpoint is not empty ;-). Probably the file was created by dolphin and can safely be deleted. Delete the file and try again.

0
2

I had a this error after being prompted to "upgrade" my secure storage to a new version (sorry, I don't recall the exact words used).

While I was somewhat panicked, it turns out the PlasmaVault GUI (Kubuntu 20.04.01) just doesn't handle some of the complexities of CryFS's interface. From the commandline I was able to resolve this:

~/Vaults$ cryfs  ~/.local/share/plasma-vault/Personal.enc/ Personal/
CryFS Version 0.10.2

Password: 
Deriving encryption key (this can take some time)...done
The filesystem id in the config file is different to the last time we loaded a filesystem from this basedir. This can be genuine if you replaced the filesystem with a different one. If you didn't do that, it is possible that an attacker did. Do you want to continue loading the file system?
Your choice [y/n]: y

Migrating file system for integrity features. This can take a while... 1%[2021-02-28 09:49:17.441] [Log] [warning] Block not found, but was returned from forEachBlock before
Migrating file system for integrity features. This can take a while... 35%[2021-02-28 09:49:17.861] [Log] [warning] Block not found, but was returned from forEachBlock before
Migrating file system for integrity features. This can take a while... 65%[2021-02-28 09:49:18.239] [Log] [warning] Block not found, but was returned from forEachBlock before
Migrating file system for integrity features. This can take a while... 100%
Migrating file system for conflict resolution features. This can take a while... 99%
Mounting filesystem. To unmount, call:
$ cryfs-unmount "/home/me/Vaults/Personal/"

I'm not sure what to make of those "Block not found" warnings, but the files appear to be in-tact. After unmounting, the GUI mounting methods appear to work fine.

Hope this is helpful to others.

1

TL;DR: just remove extraneous files from your vault directory inside the ~/Vaults

I had the same problem. My Dolphin options had "Show hidden files" enabled, so when I browsed the Vault directory with it, it created a file called ".directory" and contains some property flags.

This made the Vault dir "non-empty". Thus, when you try to remount it using Vaults, they give up - without showing you ANY info (when, in fact mounting the dir with cryfs, it gives the following error "fuse: mountpoint is not empty").

BTW, everyone online says that your .enc files are in ~/.vaults/, but that is not true for my Kubuntu 18.10. The location of .enc files are in ~/.local/share/plasma-vault/

I'm filing a bug with KDE and I will ask them to implement Vaults to show some sort of warning or message about unsuccessful mounting of the vault. Bug report here, please join me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .