12

I've installed Gnome Flashback and can select it on the log in screen: enter image description here

Unfortunately, every time I restart I'm automatically logged into the original "Ubuntu" (Gnome 3) environment again. The solutions in these related questions don't work anymore:

how to set default session in Ubuntu 14.04 LTS?

How do I change the default session for when using auto-logins?

Specifically, setting user-session to gnome-flashback-metacity in /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf has no effect.

How do I fix this?

1
  • 2
    Sounds like a bug because I have five DE's in 18.04 to pick from and whichever one I pick sticks as the default for the next login. Jun 24, 2018 at 17:20

5 Answers 5

8
$ sudo update-alternatives --config x-session-manager

(you can also add other DM via

sudo update-alternatives --install /usr/bin/x-session-manager x-session-manager /usr/bin/gnome-session-classic 60 

[assuming the new session manager is /usr/bin/gnome-session-classic :-]

0
5

You can change the default Desktop environment file in user Account file.

cd /var/lib/AccountsService/users

Select the specific user file

Here change the "xsession" value to "GNOME Flahsback (Metacity)"

2
  • I needed unity, and was able to just specify unity (after installing it for 18.04), corresponding with the .desktop file in /usr/share/xsessions/ help.gnome.org/admin/system-admin-guide/stable/… Apr 27, 2021 at 17:15
  • This is the one that worked for me. Amazon Workspaces Ubuntu 22. I changed this file ./users/<username> and it included the line session=<nothing>. I put my DE of choice there, (e.g. i3) and on reboot it actually loaded it! Sep 8, 2023 at 3:47
3

You could reconfigure your default display manager using these steps in the terminal. I am assuming that your default is gdm3 and you want to move to lightdm

$ sudo dpkg-reconfigure gdm3
<OK>
lightdm
2
  • 1
    I’ve tried this but dpkg-reconfigure doesn’t offer any choices and immediately ends with exit code 0. Jun 13, 2019 at 19:21
  • display manager and desktop are not the same, this answers a question, but a different one from the one that was asked. Jul 3, 2022 at 13:25
2

Found a workaround. Install LightDM (which IMHO looks much better than the default GDM):

sudo apt-get install lightdm

Then disable and re-enable autologin (if needed). This creates a working configuration that remembers your selected desktop environment.

1

Run sudo dpkg-reconfigure gdm and select the default display manager in the dialog that pops up. You can replace “gdm” with any of the display managers that are currently installed on your system. If this fails, you can edit the /etc/X11/default-display/manager file with root privileges https://www.makeuseof.com/tag/choose-switch-linux-display-managers/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .