1

This question already has an answer here:

Complete Linux beginner here.

I installed Ubuntu 18.04 yesterday, dual booting with Windows 8.1.

When trying to connect to a WiFi network, it doesn't detect any of the networks (not mine or my neighbors'). I tried creating a hotspot from my Android phone and to my surprise, it detected it immediately.

I searched around on the internet and tried restarting the network manager service, changing the channel on my router, and some other things, but nothing worked.

When I boot into Windows, my wifi along with all the other networks is detected and connects with no problem.

Edit: Here's the output of running lspci -knn | grep Net -A3

captaindroid@Akash-PC:~$ lspci -knn | grep Net -A3
08:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:804c]
Kernel driver in use: rtl8723be
Kernel modules: rtl8723be
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.
TL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 0a)

marked as duplicate by Pilot6, Eric Carvalho, Fabby, Charles Green, Thomas Mar 3 at 9:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please edit your question and add output of lspci -knn | grep Net -A3 terminal command. – Pilot6 Jun 24 '18 at 15:26
  • @Pilot6 I have added the output of the command you suggested. Please have a look. – Akash Srivastav Jun 24 '18 at 15:36
  • @Pilot6 I tried the suggested solution and changed the antenna both to 1 & 2, but it didn't work. I took my laptop and moved closer to the router and it detected the network. Any permanent solution? – Akash Srivastav Jun 24 '18 at 15:57
  • Did you reboot after you entered the command? – Pilot6 Jun 24 '18 at 15:59
  • Please post the output of cat /etc/modprobe.d/rtl8723be.conf. – Pilot6 Jun 24 '18 at 15:59
0

I found this from here

Doing this solved the poblem in my ubuntu 18.04

git clone git://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
make
sudo make install 

and reboot.

Not the answer you're looking for? Browse other questions tagged or ask your own question.