2

On a fresh install of the official Ubuntu 18.04 I often got random freeze on login screen, and constant freeze on shutdown and restart.

I find those 2 years old questions:

They didn't help to fix the real problem for me with Ubuntu 18.04.

2 Answers 2

2

One of the main difference between the official Ubuntu 16.04 and 18.04 release, in term of "login screen / shutdown / restart" area known by my "developer background not that much interested by the linux world" is the change of the display manager.

Ubuntu 16.04 use lightdm.

Ubuntu 18.04 use gdm. G for gnome, as the official Ubuntu 18.04 now use gnome by default. Also some flavior/variant like Xubuntu 18.04 still use lightdm.

I give a try to returning to what worked for me before using Ubuntu 18.04 release, so using lightdm like Ubuntu 16.04 over gdm and it solve the problem. When installing lightdm I get a window/prompt in the terminal asking in a "ncurse graphical interface" if I want to use gdm or lightdm, with the down-arrow I choose lightdm. I reboot the computer and I can now bootup and shutdown my computer. This is wonderful.

sudo apt-get install lightdm

As it freeze on the login screen randomly, I install lightdm in the recovery mode. Holding the shift key right after starting the machine should display the grub menu. If not press the escape key once.

Then you should be able to choose in "advanced options" to boot in "recovery mode". If you press it more that once it will go to the grub console and that's not what we want.

Don't forget to choose lightdm over gdm in the graphical prompt while installing lightdm.


I also find this topic but it seems longer to apply a fix and not sure it will solve the problem for me as my CPU is a Intel Skylake family member and not Intel Bay Trail:

I was personnaly thinking that it was all a typical NVIDIA Driver problem but it appears that it can be anything. Computers...

1
  • 1
    I no longer validate my answer :/
    – ricko zoe
    Apr 2, 2019 at 7:15
2

I am using HP18 all-in-one desktop. I was also facing the same problem after installing Ubuntu 18.04. What I did to solve the problem is:

  1. Press F10 while booting (to go to BIOS setup).
  2. Go to Advanced tab.
  3. Run down to Device Options.
  4. Enable the USB XHCI Controller.
  5. Save and Exit

I did this in random and it solved my problem. Hope this works for you as well.

3
  • 2
    Please do not repost the same answer many times. Please instead flag the questions as duplicates if the issues are similar enough to each other to be nearly identical. Reposting the same answer to many different questions is a little bit noisy and is generally discouraged where possible.
    – Thomas Ward
    Aug 30, 2018 at 19:11
  • @Aakash or anyone know the meaning of this?
    – ricko zoe
    Sep 5, 2018 at 13:42
  • I have not this option on my Asus UX501V
    – ricko zoe
    Apr 2, 2019 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.