1

I just installed the newest LTS (18.04) and ran into this problem while setting it up. I need to be able to type in Korean (Hangul); I have been using Korean in 16.04 on two machines for the past few years, and it has worked without a problem.

After Korean is added as an additional language input sources, I cannot use it. I am able to select/toggle the various input languages via the dashboard icon and using super+shift; however only English characters appear when hitting keys.

For troubleshooting, I also added Hebrew, Hungarian, and Icelandic. The Hebrew works perfectly when selected. Both Hungarian and Icelandic only have a few characters changed which may be the default functionality of those layouts; I'm not familiar with them so I cannot be sure. As per the standard, right-alt should toggle between English and Korean characters, but it does not.

Additionally, I booted into my Windows partition and the right-alt key worked fine, so it is almost certainly not an issue with the actual keyboard.

Lastly, I have also tried using "gnome tweaks" -> "Keyboard & Mouse" -> "Additional Layout Options" -> "Korean Hangul/Hanja keys" to explicitly set the right-alt functionality, but it still doesn't work.

Any aid would be greatly appreciated! If I can't get Korean working, I'll be forced to go back to 16.04 (or Windows) and I really would prefer not to.

4
  • Have you enabled "Hangul mode"? Jun 23, 2018 at 20:13
  • @GunnarHjalmarsson - I don't believe I have. Do you know where it would be located? Jun 23, 2018 at 20:27
  • When "Korean Hangul" is the current input source, you'll find that option if you click the input source indicator in the top bar. Optionally the shortcut <Shift>+<Space> toggles "Hangul mode" on or off. Jun 23, 2018 at 20:35
  • @GunnarHjalmarsson - Thank you! That wasn't the problem, but your question gave me the solution nonetheless. I wasn't using "Korean Hangul". I must have missed it; I had "Korean" & "Korean 101/104 key compatible", and was trying to get those to work. "Show keyboard layout" on "Korean 101/104 key compatible" shows right-alt as the Hangul key so I assumed it was correct. Jun 23, 2018 at 20:44

2 Answers 2

4

The solution to my problem was so simple I wanted to hit myself.

I couldn't choose Korean (Hangul) and picked Korean instead. As a result I could only use it as a modified english keyboard. I tried 3 different things people suggested to similar problems and nothing worked.

Long story short, the answer was the Tweaks application. Just go to Keyboard & Mouse and swich on Show Extended Input Sources and then restart.

After that Korean (Hangul) can be chosen in the usual language input settings.

All that was left to do was go to the toggle option in the top bar (usually showing en or ko depending on which language is in effect), then to Setup (only visible when korean is currently chosen), lastly check the box left to Start in Hangul Mode and restart one last time.

Now everything is working exactly the way it should.

This may be trivial to most of you but I for one would have appreciated a walk-through like this to save me a lot of frustration...

2
  • I am having the same problem so I followed your method and enabled Show Extended Input Sources. Now I can see two more options but still Korean(Hangul) is not there.
    – Mobeen
    Aug 8, 2019 at 6:59
  • 2
    @Mobeen - You need to first install the Korean as a language under "Manage Installed Languages" in the same dialog. After you have done that you also need to restart Ubuntu in order for it to take affect. Then you should be able to choose Korean(Hangul).
    – stenix
    Sep 15, 2019 at 7:53
2

There are multiple, 4 to be exact, options for Korean when adding an input source. To use Hangul, make sure the source is "Korean(Hangul)". In "Add an Input Source" it will have the gears icon to the right-hand side, as seen in the image below

Screenshot of Ubuntu 18.04 Region and Language settings window with Korean (Hangul) selected in the Add an Input Source window.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.