0

Audio was working just fine until a couple of days ago. Then my audio completely failed (no sound at all through any device, sound settings just showed "Dummy output" as the only option for "play sound through"). Following some advice on the forums, I updated the BIOS. That has restored my sound except that headphones or speakers plugged into the jack are not detected. On sound settings they don't show up as one of the entries in "play sound through". Normally, before when I plugged in headphones a dialogue box would automatically pop up asking whether I had plugged in headphones, a microphone or a headset. That dialogue isn't popping up any more when I plug something into the jack and I still get sound from the speakers (and not from the headphones) when I plug in headphones. The headphones also don't show up in pavucontrol. Clicking on "port" the only item in the dropdown list is Speakers. USB headphones (or my regular microphones plugged in using a usb adapter) work just fine. So I do have a way of having working headphones. But it is still puzzling that the headphone jack stopped working. I don't think it's a hardware problem. The analogue jack shows up in aplay -l, and during boot there is a "pop" in the headphones at one point, which seems to indicate that the jack isn't dead.

I have already looked at and followed advice from a number of other posts, including:

https://askubuntu.com/questions/9207...-seems-to-work https://askubuntu.com/questions/1324...ck-not-working https://ubuntuforums.org/showthread....ght=headphones Headphones no longer detected in 16.04

In particular, I've already tried killing and restarting pulseaudio, editing /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf, issuing alsactl restore, etc. I've also tried reinstalling pulseaudio.

Following the advice at https://help.ubuntu.com/community/So...otingProcedure I've run alsa_info.sh. The output from alsa_info.sh was posted here:

http://www.alsa-project.org/db/?f=0d...97654481658470

Anything else I can post to help diagnose this? Thanks!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.