1

I installed flatpak and one application. I have now removed both flatpak and that application, and I'm getting this message for AFAICS whenever I start a GUI application (for example, meld or pluma):

dconf-WARNING **: 18:37:20.153: Unable to open /home/user/.local/share/flatpak/exports/share/dconf/profile/user: Permission denied

I'm using a fresh install of Ubuntu Mate 18.04 and I don't remember seeing this before.

4
  • 2
    dconf-warnings are there for the maintainer of dconf so please report this as a bug. For the mean time I would suggest to do a ls -l ~/.local/share/flatpak/exports/share/dconf/profile/user and document the result and then do a sudo chown $USER:$USER ~/.local/share/flatpak/exports/share/dconf/profile/user and see if that fixes it. – Rinzwind Jun 23 '18 at 16:53
  • 1
    Thanks! Apparently ~/.local/share/flatpak was owned by root. (Maybe as a result of sudo flatpak install.. Is that wrong?) I simply deleted the folder (with sudo) and the issue is gone. – Joschua Jun 23 '18 at 17:54
  • I'm not sure how I should deal with this askubuntu question now.. Deleting it seems wrong, as other people might stumble upon the same problem. – Joschua Jun 23 '18 at 17:54
  • oh that's easy: you make an answer and accept it when you can – Rinzwind Jun 23 '18 at 20:23
1

For me the issue was solved by deleting the whole flatpak directory (sudo rm -rf ~/.local/share/flatpak/), but may not want to do that if you're currently using any flatpak apps or want to keep their config files.

In that case it's probably better to try to use something like this (as sugested by @Rinzwind): sudo chown $USER:$USER ~/.local/share/flatpak/exports/share/dconf/profile/user

0

I had the problem when launching Firefox by clicking a link inside a Thunderbird's message. The Firefox profile was locked, and in the terminal where Thunderbird was launched, I got the message «dconf-WARNING **: Unable to open /var/lib/flatpak/exports/share/dconf/profile/user: Permission denied». In deed, I later found there was no "/dconf/profile/user" present in the file system. Solved the issue by reinstalling flatpak packages from repository.

Thunderbird links worked again without locking the Firefox profile.

0

Do not let Firefox write in that file! , the question is why FF want to access Flatpak container settings ?

-save : ~/.local/share/flatpak/exports/share/dconf/profile/user -chown : ( let FF to write in ) -diff : than upload the diff result

--- after this you can put back the original file in place.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.