2

I installed powertop and tried to run --auto-tune as I've seen that seems to be the suggested options, however I'm pretty sure it's not actually running.

I'm on a fresh Ubuntu installation and I'm also fairly new to this. No one else seems to be having this problem either.

Here's a screenshot of my terminal

4

Now that I actually know what I'm doing I understand better how powertop works.

Here's what you should look out for if you're having trouble with Powertop:

  1. Keep Powertop running while your laptop is on battery, Powertop needs to collect information about your battery and laptop. Neither auto-tune or calibrate will run unless Powertop has recorded enough information
  2. When running auto-tune, Powertop still gives me some errors as if it had failed. It actually worked just as intended.
  3. There is no way to make auto-tune settings permanent, but what you can do is add them to /etc/rc.local, a script that will be launched on boot.

Here's mine for reference:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
sudo powertop --auto-tune
exit 0

You may need to check "Allow executing file as a program" from the file's properties.

enter image description here

To be sure if it launched, reboot and open powertop. Switch to the "Tunables" tab, if all the options there are set as "Good", then it worked.

EDIT: By the way this actually improved my battery life by about 100%. Better than I ever got with TLP, which I am no longer using as it throttled my laptop without actually improving battery that much.

| improve this answer | |
1

If you want to optimize power-management of your Ubuntu using Powertop,

  1. Open Powertop in terminal using the command : sudo powertop.
  2. Navigate to Tunable section using TAB button.
  3. Using the arrow keys select each of the "Bad" settings and set them to "Good" by pressing enter, this should ensure your computer is using your battery in an optimal way.

Or you can give a try to :

  • CpuFreq
  • Jupiter
    instead of Powertop(a command line based power-management tool).
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.