3

I have created a .desktop file for Eclipse and put it in .local/share/applications in applications launcher the icon of app is not showing up.

[Desktop Entry]
Type=Application
Name=Oxygen_Eclipse
Comment=Eclipse Integrated Development Environment
Icon= /home/amir/IDE/OXYGEN/eclipse/icon.xpm 
Exec= /home/amir/IDE/OXYGEN/eclipse/eclipse 
Terminal=false
Categories=Development;IDE;Java;
StartupWMClass=Oxygen_Eclipse

I have the same .desktop file for eclipse Luna (with path to luna folder) and that one shows the icon. I have tried .png file and another .xmp icon none of them work.

5

I had a similar issue and I fixed it by removing a stray whitespace character at the end of the Icon line. It looks like there is whitespace in you paths, what happens if you try

[Desktop Entry]
Type=Application
Name=Oxygen_Eclipse
Comment=Eclipse Integrated Development Environment
Icon=/home/amir/IDE/OXYGEN/eclipse/icon.xpm
Exec=/home/amir/IDE/OXYGEN/eclipse/eclipse
Terminal=false
Categories=Development;IDE;Java;
StartupWMClass=Oxygen_Eclipse
2
  • FWIW, I had managed to get my custom app to show up. It failed to run. I corrected the mistake but now when I type the name in the search bar it does not show up. My typo was in the Exec statement. I did check to see if I had any blank lines or spaces at the end of text. I do not.
    – netskink
    Feb 27 '20 at 20:40
  • created an account here to say thank you :)
    – grreeenn
    Sep 6 '20 at 0:58
0

I made the mistake of putting the Exec and Icon value in "'s when I removed them everything work correctly

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.