0

After installing Ubuntu 16.04 on a server machine I get an error on my monitor. It tells me that the input is out of range

I've tried following the other suggestions on here but not of them work. I'm not able to to log into Ubuntu because it won't show up

Holding shift does not bring up the grub menu or if it does it still has that error

As I can't edit anything I can't follow any suggestions

I am able to boot from a live USB is there anything I can do from there that could help?

The machine I am using is a sunfire x4600

  • Please add the complete error message to your question. Where does this error show up? Which suggestions did you try to follow? What does "Ubuntu won't show up" mean? – danzel Jun 22 '18 at 23:36
  • Hi. The monitor just says out of range. I mean the login screen – VenomSnake14 Jun 25 '18 at 12:27
  • I tried holding shift to bring up the grub menu but that didn't work. Basically the screen doesn't show anything after booting up – VenomSnake14 Jun 25 '18 at 12:32
  • Now I understand your question. The monitor tells you that the input signal is out of range. This means that your graphics adapter's output is out of the range your monitor can handle. From the live usb, open /boot/grub/grub.cfg of your server install and search for the set gfxmode= line. The current value is probably auto. You can specify grub's display resolution there, e.g. set gfxmode=640x480. Try setting it to a value that both your monitor and graphics adapter support and tell us if you can enter grub. Of course, note down the current value so you can revert it if it didn't help. – danzel Jun 26 '18 at 10:49
0

As I already explained in the comments, the monitor telling you "(input) out of range" means that your graphics adapter's output is out of the range your monitor can handle. Since that is apparently already the case in the grub environment, you should change grub's graphic configuration to a value that both your graphics adapter and monitor can handle.

The usual place to configure grub is /etc/default/grub, and you should always use that file if possible. However, you'll need to run update-grub to compile the new configuration, which can be tedious from the outside (e.g. a live system). So if you are only able to access the file system from the outside, it's easier to directly modify /boot/grub/grub.cfg. In your case, find the set gfxmode= line and set it to something like set gfxmode=640x480.

If that worked and you are able to boot and use the system, do the same change in /etc/default/grub (the setting is called GRUB_GFXMODE there and usually commented out). Otherwise, the next update-grub will overwrite your changes (for example when a new kernel has been installed).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.