1

I’m using Ubuntu GNOME 16.04 LTS. During a recent automatic software update I was shown a debconf dialog, which is something that usually never happens in Ubuntu. The configuration in question was about switching between keyboard layouts. I think I just accepted the default.

Now pressing both Shift keys switches keyboard layouts in GNOME (and probably generally in X). This is pretty bad, since I’m using the Neo keyboard layout, where pressing both Shift keys is the way to toggle caps lock.

This new Shift + Shift layout switching is apparently separate from the GNOME layout switching. GNOME layout switching still works via Super + Space and shows me the pop-up with the keyboard layouts as usual. The new layout switching, however, doesn’t show any pop-up.

How can I disable this Shift + Shift layout switching again? I already tried sudo dpkg-reconfigure --priority=high x11-xkb-utils, but this didn’t offer me any configuration options.

4

You were probably hit by bug #1762952. One way to fix it:

  1. Open /etc/default/keyboard for editing and replace the line starting with

    XKBOPTIONS
    

    with

    XKBOPTIONS=""
    
  2. Run this command to disable it from the desktop settings as well:

    gsettings reset org.gnome.desktop.input-sources xkb-options
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.