Tried restarting my computer and while it's booting Ubuntu 18.04, it gets hung up after:

[FAILED] Failed to start Snappy daemon,
See 'systemct1 status snapd.service' for details,
  • 4
    see if you can ctrl-c during the process? I've encountered the same issue and it seems like it skips through to the rest of the boot after. If you make it through, run the command journalctl -u snapd.service and include the output.
    – John Snow
    Jul 3, 2018 at 3:50
  • Could you add detailed log, it would help to narrow down issue. I have come across few links (appended at end of message) which could lead to possible solution, or at least provide a direction to find the resolution. Few links for starters... What is snapd?, Similar issue but more related to connectivity crash., SnapCraft
    – Novice
    May 22, 2019 at 6:27
  • 2
    Run this very command and post output of it in Your question : ` sudo systemctl status snapd.service`. Jul 8, 2019 at 8:06
  • Try this and if it fails, run the command: sudo systemctl status snapd.service - although I'm sure this is solved, and we can close this off ;)
    – DankyNanky
    May 19, 2020 at 10:58
  • what does systemctl status snapd.service give you ? Dec 20, 2020 at 0:57

1 Answer 1


I ran across this bug report that reflect the issue you are describing. However, the bug report indicates that, at the base level, the issue is with the kernel. So if you're not running the latest kernel, which you can check by running uname -r (I am on 18.04.05 using kernel 5.4.0-58-generic), you may want to attempt upgrading:

sudo apt update
sudo apt full-upgrade

if that does not solve the issue you may want to uninstall/reinstall snap:
Find installed snaps: snap list

  1. Remove installed snaps: sudo snap remove <packages-from-snap-list>

  2. Remove snapd: sudo apt purge snapd

  3. Remove snap directory from home: rm -rf ~/snap

    If you receive an error removing snapd then do the following:

    sudo rm -rf /var/cache/snapd 
    sudo apt purge snapd

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .