3

Nothing happen when I click icon of Chrome under VNC, tried both GNOME and XFCE. No error log in VNC. I am using TigerVNC, Here is my ~/.vnc/xstartup

#!/bin/sh
MODE="GNOME"
unset DBUS_SESSION_BUS_ADDRESS
export XKL_XMODMAP_DISABLE=1
unset SESSION_MANAGER
if [ -e "$HOME/.Xresources" ]
then
    xrdb "$HOME/.Xresources"
fi

if [ "GNOME" = "$MODE" ]
then
    if which gnome-session > /dev/null
    then
        gnome-session --session=ubuntu &
    else
        MODE=""
    fi
fi

If I enter google-chrome under terminal, I will get error:

[7027:7027:0622/011058.037849: ERROR:sandbox_linux.cc(378)] InitializeSandbox() called with multiple threads in process gpu-process.

I can open other programs like Firefox under VNC without issue.

Update 2018-06-24:

If I delete ~/.config/google-chrome, I can open Chrome under VNC, but it took about 60 seconds to show up...

Once I logged in my Google account and close Chrome, I can not re-open it again...

1

There appear to be two issues here.

  1. GPU acceleration. You can resolve this by running

    google-chrome --disable-gpu
    
  2. gnome-keyring-daemon. This is a fairly common problem with a number of workarounds. The most acceptable to me is to execute this before launching chrome:

    gnome-keyring-daemon --replace --foreground --components=secrets,ssh,pcks11
    

However, you may find one of the other options more acceptable.

0

You need to:

  1. kill all chrome processes
  2. kill the gnome-keyring-daemon
  3. start chrome in VNC.

That worked for me in Fedora 28 with Chrome Version 73.0.3683.103 (Official Build) (64-bit)

I had the EXACT same issue and error message. I started using VNC :11 and on the main displkay doing vnc to 127.0.0.1:11 so that I can jump to another desktop on get to my desktop via chromebook and back without loosing my work.

Yes I could just vino but VNC is easier and I don't have it autostart so it's easier to secure (manually turn it on only when needed then off when I don't, etc) and easier to start on a mate desktop as I am NOT a gnome 3 fan at all! If I want to see fancy graphics/animations I'll play *craft from blizzard or go watch cartoons. :-D

-1

it is fixed by sudo apt install gnome-keyring

after starting chrome again .. wait somewhat longer than usual.

Et wholla!

  • 2
    I already have gnome-keyring installed... not working – Yuji Jun 27 '18 at 2:42
  • In many cases definitely not fixed by installing gnome-keyring – Johsm Mar 15 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.