0

I applied some system updates and after the updates I realized that copy&paste wasn't working anymore. I remembered that this usually happens after a kernel upgrade.

I tried reinstalling open-vmtools but that failed even after purging. So I tried to install the vmwaretools shipped with vmware. But this "fails" at the step where it asks for kernel headers. It just keeps saying the supplied path is invalid.

The path "" is not a valid path to the 4.4.0-128-generic kernel headers

I followed below tips but it did help with the issue:

What is the path to the kernel headers so I can install vmware?

The path " /usr/src/linux-headers-$(uname -r)/include" is not a valid path...

So what should I do?I'm lost...

1 Answer 1

0

I could not reinstall open-vm-tools even after purging. Hence I tried with vmware tools and got this error. I can't provide a solution for it but playing around more, I removed vmware tools again and installed open-vm-tools (and open-vm-tools-desktop, the package causing the error!). And for some unknown reason now it worked.

I rebooted and still no copy&paste but resizing worked. I googled further and found the solution in below question:

Copy/paste and drag&drop not working in vmware machine with Ubuntu

  1. Go into VM / Settings / Options / Guest Isolation
  2. UNCHECK bothcheckboxes (Enable drag and drop, Enable copy and paste) and click OK.
  3. Shut down the guest, and shut down VMware Workstation
  4. Reboot the host computer
  5. Run VMware Workstation but do not launch the guest yet.
  6. Go into VM / Settings / Options / Guest Isolation for the guest, and
  7. CHECK both checkboxes
  8. Power On the guest.

And now copy&paste works again with open-vm-tools

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.