0

I have successfully installed Abaqus 2017 on Ubuntu 16.04, but fail completely on any newer Ubuntu version. Here is the routine that leads to the problem.

All prerequisites that are listed here (install ksh and what not) are met.

Then, the usual shell script edit has to be made to mimic a supported OS (see also here). From the folder where StartGUI.sh and StartTUI.sh sit I run

vi ./inst/common/init/Linux.sh 

and insert at line 4

DSY_OS_Release="CentOS"

Running then StartGUI.sh produces the error

ERROR: Cannot wait for process "/home/gluege/Software/ABQ/2   
/SIMULIA_AbaqusServices/Linux64/1/inst/linux_a64/code/bin  
/DSYInsAppliTUI" "-CDpath" "/home/gluege/Software/ABQ/2  
/SIMULIA_AbaqusServices/Linux64/1/"

An inspection shows that ./inst/linux_a64/code/bin/DSYInsAppliTUI cannot find the shared libraries that are to be found in ./inst/linux_a64/code/bin/ (as seen from the folder where StartTUI.sh is located).

Upon adding the path to the default library search folders by

LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/gluege/Software/ABQ/2
/SIMULIA_AbaqusServices_CAA_API/Linux64/1/inst/linux_a64/code/bin/

and informing the OS by

export LD_LIBRARY_PATH

the error message when running ./inst/linux_a64/code/bin/DSYInsAppliTUI becomes

Cannot change log file to /InstallData-2018_06_21-180430+0100   
/log/2018_06_21-180430+0100/Replay.xml  

Error stack:  
Unable to create the directory '/InstallData-2018_06_21-180430+0100', reason:  
Error num: 13  
Permission denied  
Error code: Type: FATAL, Error: 2, Owner: 103

I find it strange that the installer wants to put logs in the root folder, but anyway: I suppose that this issue could be resolved by executing all scripts with root privileges. So I run

sudo env LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/gluege/Software/
ABQ/2/SIMULIA_AbaqusServices_CAA_API/Linux64/1/inst/linux_a64
/code/bin/ ./inst/linux_a64/code/bin/DSYInsAppliTUI -CDpath
/home/gluege/Software/ABQ/2/SIMULIA_AbaqusServices/Linux64/1/

to start the terminal-based installer, exporting the library path before the command. The installer starts, but instead of showing the text strings, the variable names are shown, like so:

DSYInsControler.Title.Template(3DEXPERIENCE R2017x, Abaqus Simulation
Services, , DSYInsControler.Welcome.Title())
___________________________________________________________________
DSYInsControler.TextTUI.DefaultSelection(Next)

It is impossible to go through the installation like this, who knows what other variables are not accessed correctly. Applying the same technique sudo env ... to the real installation entry point StartTUI.sh just produces the above error Cannot wait for process.

So, what can I do to get the installer running? Does anyone know what exactly breaks the installer when going from 16.04 to 18.04??

  • Installing abaqus 2018 and abaqus 6.14 worked on Ubuntu 18.04 for me. However, somehow the standard process (implicit) cannot terminate properly after the analysis has completed. As soon as I'm back to my PC with the ABQ install I can see if I can help you with your problem. In any case I didn't have similar problems. – David Jul 2 '18 at 7:12
  • I really don't see where the problem is... I guess it's a linux partition (not FAT nor NTFS), right? – David Jul 24 '18 at 6:34
  • @David Have you found a way to fix the problem of non-terminating simulations? I'm having the exact same issue with 6.14 on Ubuntu 18.04. – Christoph90 Jul 25 '18 at 10:05
  • @Christoph90 unfortunately, not yet. I'd suggest either your or me to create an ad hoc question, in order not to go off topic here. By the way, I found a user saying that he doesn't have any problem on 18.04. check it out here home.iitk.ac.in/~saiwal/computing/install-abaqus2016-ubuntu – David Jul 26 '18 at 7:39
  • @David: That user installs on Ubuntu 16, which works fine. The trouble starts with Ubuntu 18. I will just follow your first comment and get the combination Abaqus 2018 : Ubuntu 18. – Rainer Glüge Jul 26 '18 at 7:50
0

Probably you'll need to copy libpng12.so.0 to all folders //linux_a64/code/bin/

Here is a manual on how to install Abaqus on Ubuntu (libpng12.so.0 is also there):
https://github.com/imirzov/Install-Abaqus-2019-on-Ubuntu-18.04-LTS

0

I had a similar problem in a different environment (cough, windows, cough). The problem was related to the decompression utility used to, well, decompress the installation files. By using 7zip, the installation went as smooth as possible.

So my suggestion is to use another unzipping utility.

Good luck,

Leandro

  • Thanks for the hint, but I think it does not apply in my case. I did not extract the files, but received them unpacked. And the same files could be installed on Ubuntu 16.04. It must have something to do with Ubuntu changes between 16.04 and 18.04. – Rainer Glüge Jun 26 '18 at 20:52
0

Check that your stack size is not unlimited. You can modify it with ulimit

ulimit -s 8192

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.