1

This is a weird problem I've run into while using Ubuntu 18.04. A lot of the things in the web are somehow misplaced. The browser I'm talking about is Firefox (latest), though the issue (with the icon shift, haven't tested the cursor) persists on Chrome.

For example, the cursor in the Stack Overflow question editor and the GitHub online file editor seems much shorter than it should be.

short cursor

A plain textarea seems fine, though

textarea

Then the icons have this problem. Here's how the icons in the GitHub Gist Preview look like. As you can see, they are shifted down from the center.

icon shift

At last, the icons in the Firefox Inspector are also shifted down (which seems completely unrelated to any CSS rendering issues). In the following screenshot, the "+" and the color picker are shifted down.

inspector

The issue was first encountered on an upgrade from 17.10 to 18.04, then I did a fresh reinstall of 18.04, but the problem remains.

What could cause this? Has anyone encountered anything similar?


Edit about the modifications I've made to my GNOME Shell:

  • Install Roboto fonts (sudo apt install fonts-roboto-hinted)
  • Install Materia theme (Shell and GTK+)
  • Install Numix-Circle icons
  • Install Materia GDM theme (more about it here)

Undoing all those modifications didn't seem to fix the bugs.

My Ubuntu is installed on a physical machine (not a VM), I am using X11, but the problem persists on Wayland.


Another edit: I just tried to live boot a fresh Ubuntu 18.04, the inspector icons were offset even there.

  • 1
    @dsstorefile1 both, as it seems – illright Jun 21 '18 at 14:58
  • i assume you use x11 in your ubuntu 18. Did you installed different fonts or did you made any change in the in themes? Do you get any serious error mmessages in you dmesg ? – abu_bua Jun 21 '18 at 16:22
  • @abu_bua yes, I've installed Roboto using the following command: sudo apt install fonts-roboto-hinted. I am using X11, but as I mentioned above, the problem persists in Wayland. Not sure about how to sift through the dmesg output to find errors – illright Jun 21 '18 at 17:19
  • you can get an error output using the command dmesg --level=err,warn . btw: do run a virtual machine like virtualbox or is your ubuntu machine a real one? – abu_bua Jun 21 '18 at 17:28
  • @abu_bua no, nothing relevant in dmesg. Check out the edit – illright Jun 21 '18 at 17:34
0

You can try to change fonts settings in the tweaks menu.

Install tweaks with

sudo apt-get install gnome-tweaks

and invoke it.

Under the fonts menu change hinting to Slight and the Antialiasing to Subpixel or whatever is the best for your graphics.

  • Nope, tried different settings, that didn't work – illright Jun 21 '18 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.