0

I recently installed a fresh Kubuntu 18.04 on my Laptop, most things worked fine out of the box, including most of the multimedia keys for adjusting brightness etc. However, when I press the shortcut for Audio Up, Audio Down or Toggle Audio On/Off (FN+ F10-12), it always repeat presses them until I press a different button or put a different window in the foreground. This means It keeps toggling sound on/off or keeps adjusting volume up/down until it is at 0%/100% respectively. It also keeps playing the sound effect repeatedly. The buttons worked fine on Windows 10, so it's likely not a hardware issue. Keyboard is set to generic 105 key (intl.).

I have seen Volume Control keys duplicating on key press, but the proposed solution doesn't work for me. fn+f10-12 isn't recognised as an input by the system settings for some reason.

  • Which brand of laptop? I'm using a Dell laptop and the volume and mute keys work just fine. – DK Bose Jun 21 '18 at 14:24
  • it's a Medion laptop. – David Jun 22 '18 at 0:18
0

This seems to be an issue with Medion laptops on Linux. I have this problem as well, and there are reports here and here of a similar behavior. It seems that the keyboard of these laptops only sends key press events and not key release events when pressing these three Fn keys. Not sure if this is a hardware problem or some sort of "misunderstanding" between keyboard and OS.

One possible workaround is to go to Keyboard settings > Shortcuts, and map Windows-F10,F11,F12 to the appropriate command:

sh -c 'pactl set-sink-mute 0 toggle'                            Super+F10
sh -c 'pactl set-sink-mute 0 0; pactl set-sink-volume 0 -5%'    Super+F11
sh -c 'pactl set-sink-mute 0 0; pactl set-sink-volume 0 +5%'    Super+F12

and instead of pressing Fn-F10,F11,F12 you'd press Windows-F10,F11,F12.

EDIT: I've posted the answer here.

  • Thank you for posting this here! I tried following your steps from the other post and it didn't work for me. the volume keys stopped working completely after running udevadm trigger --verbose --sysname-match="event*", and reverted back to their old behaviour after rebooting Linux. Any idea what might cause this? I'm on a Medion p6661 MD99843. – David Aug 6 '18 at 11:05
  • 1
    Nevermind, I was able to fix it, you provided all necessary information in your other post. Checking /sys/class/dmi/id/modalias revealed that my keyboard's vendor ID was Medion, not MEDION. After changing the line in the fix from evdev:atkbd:dmi:bvn*:bvr*:svnMEDION:pnP*:pvr* to evdev:atkbd:dmi:bvn*:bvr*:svnMedion:pnP*:pvr*, everything works. Thank you! – David Aug 7 '18 at 8:03
  • @David: thanks; good to know. Since I preferred a more general solution I've re-edited it and just duplicated the line so that it matches both MEDION and Medion. – cousteau Aug 17 '18 at 14:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.