12

I am trying to disable automatic update checks on Kubuntu 18.04. I have unticked the option to check for updates daily by using Settings -> Configure Software Sources -> Updates in muon but the system keeps checking for updates on every startup.

The contents of /etc/apt/apt.conf.d/10periodic are

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";
APT::Periodic::Unattended-Upgrade "0";

Is there anything else that has to be done in order to stop those automatic checks completely?

7
  • How often you do start up? Is it more than once a day?
    – DK Bose
    Commented Jun 21, 2018 at 10:54
  • No, unless the system needs to reboot after an update or an installation. Do you mean that the update checks the system does during startup, do not depend on the setting I have unticked?
    – Stormlord
    Commented Jun 21, 2018 at 14:29
  • I don't have /etc/apt/apt.conf.d/10periodic. Could you run sudo -H software-properties-kde to get a window titled Software Sources . It has an Updates tab. Maybe try turning things off there?
    – DK Bose
    Commented Jun 21, 2018 at 15:06
  • That's exactly what the muon setting I described above does. It runs software-properties-kde.
    – Stormlord
    Commented Jun 21, 2018 at 15:14
  • Then I don't understand why I don't have /etc/apt/apt.conf.d/10periodic. Did you create that file yourself?
    – DK Bose
    Commented Jun 21, 2018 at 15:21

3 Answers 3

5

To disable automatic upgrades in Kubuntu 18.04, run:

$ sudo dpkg-reconfigure --priority=low unattended-upgrades

and when prompted Automatically download and install stable updates?, choose "No" and follow the remaining prompts. To see the status of automatic upgrades, run:

$ apt-config dump APT::Periodic::Unattended-Upgrade

The value produced (an integer) means how often to update automatically, in days. A zero value means disabled.

4

At my 18.04.1 installation there was no file /etc/apt/apt.conf.d/10periodic.

After a short search I found:

/etc/apt/apt.conf.d/20auto-upgrades

There I could disable my auto-updates. Maybe you could also have a look there for your solution.

I just zero-ed the values; so my content of /etc/apt/apt.conf.d/20auto-upgrades is now:

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Unattended-Upgrade "0";
APT::Periodic::Download-Upgradeable-Packages "0";
0

Changing those values in periodic only seem to disable the automatic update of package lists.

To disable the annoying update-manager popup (also called update-notifier), I changed the file /etc/apt/apt.conf.d/99update-notifier from this:

DPkg::Post-Invoke {"if [ -d /var/lib/update-notifier ]; then touch /var/lib/update-notifier/dpkg-run-stamp; fi; /usr/lib/update-notifier/update-motd-updates-available 2>/dev/null || true";};
APT::Update::Post-Invoke-Success {"/usr/lib/update-notifier/update-motd-updates-available 2>/dev/null || true";};

to this content:

//DPkg::Post-Invoke {"if [ -d /var/lib/update-notifier ]; then touch /var/lib/update-notifier/dpkg-run-stamp; fi; /usr/lib/update-notifier/update-motd-updates-available 2>/dev/null || true";};
//APT::Update::Post-Invoke-Success {"/usr/lib/update-notifier/update-motd-updates-available 2>/dev/null || true";};

Finally, no more annoying notifications aka. popups.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .