2

I create a RAID 5 Volume with 5 Hard Disks by Hardware RAID, and intend to install ubuntu-server 18.04 by USB.

First I encounter MODSIGN: Couldn't get UEFI db list, unable to open /dev/sda enter image description here

after few seconds it automatically jumped to ubuntu installation scene. next error happened at partition. I am going store OS System (/, /boot) under a non-RAID Hard Disk separated from RAID Volume, and put /home under RAID Disk, as long as I selected any RAID Disk, the failed screne will show:

An error occurred during installation curtin command install ...

enter image description here

more detail log: mdadm: (non-fatal) write to /sys/class/block/md127/md/sync_max failed Permission denied enter image description here

I can successfully install ubuntu-server 18.04 on a Non-RAID Disk, but this error happened at any time I choose a RAID Disk to for whatever partition like /, /boot or /home. How to solve it ?

3

I have the same error.

Why?
You use this Ubuntu server version http://releases.ubuntu.com/18.04.1/ubuntu-18.04.1-live-server-amd64.iso named live-server.
This version use new subiquity installation system without RAID support.

Solution: if you want to install Ubuntu with RAID, you need to use Ubuntu with old installation system available here: http://cdimage.ubuntu.com/ubuntu/releases/bionic/release/

| improve this answer | |
  • Thank you harobed, alternative is the right way. I figured they got it all worked out since it's an option again in the live-server install. I figured wrong... – dgreene Oct 15 '18 at 1:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.