-1

I'm running Kubuntu 18.04 and firefox 60.0.2. I needed to use flashplayer, so I installed it, restarted firefox and enabled it. But when I tried to make it work, it doesn't reproduce anything: the part of the web page where the video should be is just white instead. The same thing happens with this (point 5): https://helpx.adobe.com/flash-player.html , so it's not the web page. Does anybody know what should I do to make it work? Or knows another plug-in that works the same?


Edit: I have another computer with Lubuntu 18.04 and it doesn't work on it either

Edit nº2: if I open the web page with chromium it displays everything

4
  • How did you install it? This guide applies largely for Kubuntu as well. Jun 20 '18 at 22:55
  • I used exactly that guide
    – amaralli
    Jun 20 '18 at 22:59
  • Weird. Is it visible if you go to Add-ons -> Plugins in FF? Jun 20 '18 at 23:03
  • Yes. I have it configured to "Ask to Activate". When something that needs the flashplayer appears on that position appears a sign that tells you to click to activate it, but when i do it it turns white where the video or animation should be.
    – amaralli
    Jun 20 '18 at 23:23
1

If you have "Ask to Activate" set, and when you are on a page which requires Flash, you need to click the "Manage plug-in use" icon to the left of the address field and click the "Allow" button.

Edit:

If I install both adobe-flashplugin and browser-plugin-freshplayer-pepperflash, I can reproduce the issues you describe, so I suppose that you have those packages installed too. However, browser-plugin-freshplayer-pepperflash seems to be buggy, so if you uninstall that package while keeping adobe-flashplugin it will probably start working for you.

1
0

I know the problem. This is actually one of multiple steps.

First of all, Ubuntu offers a number of flash solutions. Like the adobe-flashplugin the installer and the there is also the pepperflash-nonfree solution. A few versions back it also had to be a particular package and other didn't work.

Next problem is, that this still doesn't install the plugin everywhere the browsers want it to be.

Next problem is, that Chromium and Firefox are using 2 different flash player plugins. You will find that out, if you try downloading it directly.

And the most recent problem is, that now vendors for various browser are trying to get rid of flash player, since it is outdated technology and has caused a lot of trouble in the past years.

And the worst thing is, I had it disabled for years but I'm responsible for 2 devices of game players, who need it.

So, taking a look, installed on those are the flash player installer and the pepperflash-nonfree plugin. Although this too seems a bit outdated to me. But "never touch a running system".

The real solution is self-made. Back then, Firefox actually told in the error, where it wants the plugin and mentioned more than one directory. After trying various options for a while I had enough. So, I created a script that puts it in a number of directories, where the browsers seem to search.

First, go to the Adobe website and download BOTH flash player plugins for your according Linux. The link is: https://get.adobe.com/de/flashplayer/otherversions/

Select Linux, I guess 64-Bit? And get both, the PPAPI and the NPAPI.

This should give you 2 tarballs. After extration (tar xavf FILENAME), you will find two .so files among the extracted. They are fairly obvious. This is actually all you need.

Now distribute them to the according directories (some of them you will have to create the first time). Those directories are:

/opt/google/chrome/
/opt/google/chrome/PepperFlash/
/opt/google/chrome/plugins/
/usr/lib/flashplugin-installer/
/opt/google/chrome/plugins/
/usr/lib/pepperflashplugin-nonfree/
/var/cache/pepperflashplugin-nonfree/

To be honest, this might cross the line a bit. But it actually works. Yes, also for Firefox.

As I said, I created a script or 2 to be precise. I create a particular directory in the Downloads directory, where I put only flash player upgrades. I use the first script clean the directory from old files. Then I download the 2 files directly from the Adobe website (since the download link changes with the version) the second script extracts the tarball and distributes the .so files to the mentioned directories.

For me, that takes care of everything and solves the problem. As I said, I have 2 people using Ubuntu and they play a lot of browser games. And for them it has been working perfectly ever since.

This should do the trick. Chromium earlier had settings for the flash player, but I think this has changed in newer versions. With Chromium you can permit websites to use Flash Player in the content settings. Firefox usually asks when you open pages, if you want to permit the page to use Flash Player.

In regards to your edits: that is because Chromium usually comes delivered with the Flash Player and integrated already, while Firefox does not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.