MAAS 2.4 is based on Ubuntu 18.04.

  • I have both my master and nodes, connect to the public network and private network.

  • My router provides DHCP on 172.16.199.0/24 (Public Network, Gateway 172.16.199.1, DNS 192.168.111.90).

  • MAAS master provide DHCP on 10.1.1.0/24 (Private Network)

    172.16.199.0/24 10.1.1.0/24

Now, I can commission, deploy Ubuntu 18.04 and SSH to my nodes. But, my nodes can not automatically connect to the public network, I find that all the requests are directed to the private network (10.1.1.100 is my MAAS master).

I must run this command on my nodes to access to the public network:

sh route add default gw 172.16.199.1 

Every time when I reboot my nodes, I have to run that command.

  • Welcome to Ask Ubuntu! Could you please post text files, dialogue messages, and program output listings as text, not as images? To achieve the latter two you can either 1) select, copy & paste the dialogue text or terminal content or 2) save the program output to a file and use that. Longer listings (the editor will tell you what’s too long) should be uploaded to a pastie service and linked to in the question. Thanks. – David Foerster Jun 20 at 20:11

what is the gw on your 10.0.0.x network used for ? As declaring a gw on both interface will create 2 routes for 0.0.0.0 on your machines.

Try to remove the gw on the 10.0.0.x network and this should work. If you need to reach specific network via the 10.0.0.x then create the static routes for them.

Cheers

I have solved that problem by:

    sudo maas login username
    maas username interface set-default-gateway nodeID TheInterfaceID

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.