I am running Ubuntu 18.04 on a CLEVO notebook and have the nvida-390 drivers and Cuda installed. It worked fine for a month, but - suddenly today it stopped working. I can still access the login screen, but the screen remains purple.

I've already tried to purge and reinstall the nvidia-390 drivers (I've also tried the 396 drivers version) without success. After the login the computer always stops working. I cannot even access tty. After purging the drivers I can login and all works fine with nouveau, but I really need Cuda for my work.

My specs:

  • i7-6700HQ
  • 8GB RAM
  • Nvidia GeForce GTX 970M
  • Intel Wireless 8260

Can someone please help me? Thanks.

  • Try booting an old kernel – Panther Jun 20 '18 at 17:28
  • 2
    Please try out whether booting with the parameter nvidia-drm.modeset=1 solves the problem. :) – cl-netbox Jun 20 '18 at 17:40
  • @cl-netbox it worked!! Thank you! Please answer the question so i can give you the actual right answer :) – Daniele Gamba Jun 20 '18 at 17:58

You might need to have Direct Rendering Manager Kernel Mode Setting enabled on system boot.
NVIDIA driver's PRIME Synchronization support relies on DRM-KMS, which is disabled by default.
Find more comprehensive information in the discussion on the NVIDIA GPU Unix Graphics Forums.

Execute sudo nano /etc/default/grub and add the parameter nvidia-drm.modeset=1 to the line GRUB_CMDLINE_LINUX_DEFAULT. Save the change you've made and run sudo update-grub.
Restart the Ubuntu operating system, and now, everything should work properly - right as expected.

  • 5
    Congrats on bounty you deserve it :) – WinEunuuchs2Unix Jun 24 '18 at 17:27
  • Once I do this, the monitor running on NVidia will block on "Starting Gnome DISPLAY Manager" however the other monitor is fine. Remove the modeset from GRUB then all is fine, except screen tearing on NVidia. Any ideas how to diagnose or fix ? – abdelrahman-sinno Nov 14 '18 at 14:24
  • @abdelrahman-sinno Without knowing any further details providing you with a correctly working solution is not possible. I suggest that you ask a new question including as much information as possible about your specific hardware and system setup and about what you have already tried so far to solve the problem. :) – cl-netbox Nov 14 '18 at 15:25
  • @cl-netbox I have posted my question here (askubuntu.com/questions/1093409/…), please let me know if you need any further info – abdelrahman-sinno Nov 16 '18 at 9:15
  • 2
    didn't work for me – fccoelho Dec 10 '18 at 14:35

I was able to get it working with the latest Nvidia-418 drivers on a Lenovo W530 with the Nvidia GK107GLM Quadro K2000M:

  1. Edit the sudo nano /etc/default/grub and remove "quiet splash" from GRUB_CMDLINE_LINUX_DEFAULT and then sudo update-grub (that may be similar then adding nvidia-drm.modeset=1)
  2. Switch to LightDM: sudo dpkg-reconfigure lightdm (necessary so my second monitor was recognized)
  3. Install PPA with latest drivers: sudo add-apt-repository ppa:graphics-drivers/ppa and sudo apt-get update
  4. Install latest recommended driver (in my case Nvidia 418): sudo ubuntu-drivers autoinstall

Not the answer you're looking for? Browse other questions tagged or ask your own question.