2

I am trying to install CUDA-9-0 on Ubuntu 18.04, but I get the following error when I run the command sudo apt install cuda

The following packages have unmet dependencies:
 cuda : Depends: cuda-9-0 (>= 9.0.176) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have nVidia-driver-390 properly installed installed. I try to install CUDA using .deb local file installation method as described on the website of nVidia Here

I use the .deb file for Ubuntu 17.04

Does anyone has an idea how to solve this?

  • Show the repository which you try to use for this package installation. – mariaczi Jun 20 '18 at 10:35
  • There is no repo, as I stated in my question, I am using .deb local file installation method – Peshmerge Jun 21 '18 at 6:18
1

I have solved the problem by removing the nVidia driver and reinstalling it. What I did is :

sudo apt purge nvidia*

and then re-installed it using:

sudo apt install nvidia-390

I am using ppa:graphics-drivers/ppa for nVidia drivers. The repo is added using:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

I don't know what was the reason, but as you see removing and re-installing solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.