I'm fairly excited for Unity, as it looks like a promising new direction for Ubuntu. However, I do have a concern - will it be possible to use Unity without the global menu?

I have my window manager set to focus-follows-mouse/sloppy focus, and find the productivity gains to be immense. Sloppy focus is incompatible, however, with global menus, as it is possible for the focus to change while you move from window to menu.

Will Unity support an option to use window menus while still using Unity?

up vote 111 down vote accepted

11.04 - 13.10

Yes, the Desktop version of Unity will use the global menu by default.

  • To disable the global menu remove the indicator-appmenu Install indicator-appmenu package, then log out and back in.

Unity will continue to run without it and your menus will appear inside the application windows as normal. You can also tell the appmenu to ignore specific applications if you're having a problematic app.

The command line way to remove the package is:

sudo apt-get remove indicator-appmenu

Removing the appmenu will break the HUD feature

  • 2
    There is an utility that helps this: see webupd8.org/2012/03/unsettings-tool-to-disable-global-menu.html – Rmano Mar 14 '12 at 8:06
  • I hate the global menu and for that reason mac os too. Thanks for your tip. – harry Oct 18 '13 at 9:38
  • @Rmano thx vm! good I read it.. your comment should actually be an answer as it works great and I can keep my indicator-appmenu!!! if you do it, point out so I come promptly vote up! – Aquarius Power Jan 17 '14 at 2:04
  • good option but I have a problem with QT applications (notepadqq for instance): the menu dissapear at all – user260881 Aug 14 '15 at 4:11
  • In many cases it might be better to instead use the other answer to move the menu to the title bar. However removing the appmenu package will solve the problem of having no menu with x11 forwarding where as changing it in the settings wont do that. – jgmjgm Feb 14 '17 at 22:23

14.04

The Global Menu can be optionally switched in favour of Local Integrated Menus (LIM) - aka - more traditional window based menus.

The reason for this additional ability is ostensibly due to the increasing prevalence of high-resolution displays and as such the perceived mouse-travel from application to the global-menu would be relatively large.

To toggle the global menu off or on can be achieved via the appearance control-panel applet:

pic

pic

pic

Once clicked, the application menus appear within the window decoration as shown here:

pic


Command line.

The above can be achieved using the terminal command:

gsettings set com.canonical.Unity integrated-menus true

Integrated menus can be disabled (i.e. switch global menu back on)

gsettings set com.canonical.Unity integrated-menus false

If you dont like Locally Integrated Menus then the old trick of removing indicator-appmenu still works although this will break the HUD

sudo apt-get remove indicator-appmenu

enter image description here

  • A bit more about how these menus work: Better Late Than Never: Ubuntu Add Locally Integrated Menus to 14.04 – Håkon A. Hjortland Apr 14 '14 at 6:01
  • "in window title bars" works perfectly, this global menu was utterly annoying when using Gimp.. thx!! – Aquarius Power Jun 13 '14 at 20:22
  • While the "locally integrated menus" option still hides them (irritatingly) sudo apt-get remove indicator-appmenu actually gets the menus permanently back below the title bars. I don't notice anything "broken" - care to explain that note? – Jeff Ward Feb 24 '15 at 20:49
  • This also works for 16.04, but the screenshots would be slightly different. – Reinier Post May 17 '17 at 17:28

For reference, here is how to disable the global menu on a per application basis: https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationMenu#Troubleshooting

To disable appmenu support on a per application basis, set the UBUNTU_MENUPROXY variable to null, with:

env UBUNTU_MENUPROXY= eclipse

the env keyword is useful if your trying to launch the application with the ALT-F2 shortcut.

11.04 - 13.10 - How to disable the global menu (appmenu / application menu)

For current user only, all applications

Add this to ~/.gnomerc and log out of the desktop and in again:

STARTUP="env UBUNTU_MENUPROXY= $STARTUP"

For current user only, only applications launched from the shell

Add this to ~/.bashrc and restart the shell:

UBUNTU_MENUPROXY=

For current user only, only for specific applications launched from the shell

Add lines like this to ~/.bashrc and restart the shell:

alias gvim='UBUNTU_MENUPROXY= gvim'

Based on https://askubuntu.com/a/132581/32651.

For current user only, only for specific application launchers

See https://askubuntu.com/a/6802/32651.

For all users, all applications (fix it in /etc)

Create config file with fix (note that the parentheses are part of the command):

(umask 022; echo UBUNTU_MENUPROXY= | sudo tee /etc/X11/Xsession.d/81ubuntumenuproxy)

After this, log out of the desktop and in again.

To remove the fix:

sudo rm /etc/X11/Xsession.d/81ubuntumenuproxy

Based on http://www.webupd8.org/2011/03/disable-appmenu-global-menu-in-ubuntu.html.

For all users, all applications (uninstall packages)

Ubuntu 11.04 and 11.10:

sudo apt-get remove appmenu-gtk indicator-applet-appmenu indicator-appmenu

Ubuntu 12.04:

sudo apt-get remove appmenu-gtk appmenu-gtk3 appmenu-qt indicator-appmenu

After this, log out of the desktop and in again.

To undo, just install the packages again: sudo apt-get install [...]

From http://www.webupd8.org/2011/03/disable-appmenu-global-menu-in-ubuntu.html.

Notes 1

Just doing

sudo apt-get remove indicator-appmenu

will still give problems with gvim and image viewers etc. since UBUNTU_MENUPROXY will still be set to 'libappmenu.so' by the appmenu-gtk and appmenu-gtk3 packages.

Notes 2

The default value is UBUNTU_MENUPROXY='libappmenu.so'. The UBUNTU_MENUPROXY= statement clears the variable. Note that export [...] is not required when changing an already existing variable.

See also

  • Gvim might spit out this warning 25 seconds after being started:
    ** (gvim:20320): WARNING **: Unable to create Ubuntu Menu Proxy: Timeout was reached
    To fix this, either disable global menu, at least for gvim, or fix gvim.
  • Delayed in-window menu creation is a problem in image viewers etc., for example eog.
    To fix this, disable the global menu properly, at least for those applications.
  • Get both global menu and in-window menu:
    APPMENU_DISPLAY_BOTH=1
    See https://askubuntu.com/a/6802/32651.

References

  • Recent upgrade to Ubuntu 13.10 broke my old settings and had the global menu bar enabled. Thanks for your detailed answer, it worked. – harry Oct 18 '13 at 9:44

I have been successfully using unity with focus follows mouse and the global menu by only accessing the application menu via the f10 key shortcut. In many ways this is better than moving the mouse away from where ever you were focused on anyway.

11.10

To disable the menu, instead of removing the indicator-appmenu you could hide its shared library file:

sudo mv /usr/lib/indicators/5/libappmenu.so /usr/lib/indicators/5/libappmenu.so.old

and to reenable, undo it:

sudo mv /usr/lib/indicators/5/libappmenu.so.old /usr/lib/indicators/5/libappmenu.so

source

11.10

I successfully disabled the global application menu by following the advice from http://www.addictivetips.com/ubuntu-linux-tips/how-to-disable-global-menu-in-ubuntu-11-10-tip/.

I deinstalled the packages appmenu-gtk3, appmenu-gtk and appmenu-qt by running:

sudo apt-get remove appmenu-gtk3 appmenu-gtk appmenu-qt

Apparently, you can get the functionality back by reinstalling the packages.

18.04

Maybe there is an more-obvious way that i missed, but this somehow did the trick:

sudo apt-get install gnome-tweak-tool
gnome-tweaks

Go to "Top Bar"

enter image description here

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.