6

This is something I have noticed happening for a long time now, and I see it in various flavours of Ubuntu. At the moment I happen to be using Ubuntu Studio.

As the system boots past grub, you get a nice graphical Ubuntu Studio animated logo for a while, but then, just before the login screen appears, it drops back to the text console, where you see various things at different times (like system startup logging - as you'd see if you pressed escape while Plymouth is displaying the logo, and even a login prompt at times), but typically it at least shows the filesystem status (as clean usually), then it switches back to graphical mode for the login dialog.

It would look very much neater if it didn't flash the text console on screen like this. I am just wondering why it does this, and would like a fix? I know it's no biggy. I just get curious about odd things :)

  • 1
    It sounds like File System check is being run every boot. You can change it to customary every 30 boots / once per month: askubuntu.com/questions/383114/… – WinEunuuchs2Unix Jun 20 '18 at 10:52
  • 2
    Probably the best that can be done is to make the kernel as quiet as possible, so that when it does flash, all you see is a black screen. – muru Jun 25 '18 at 2:34
  • 1
    The only reason to press Escape during Plymouth is to see the startup messages. Pressing Escape during Plymouth will not make the machine boot faster nor bring the login screen up quicker. As muru's link indicates my screen goes black after Plymouth and before Login screen because of the first five options in my kernel boot parameter list: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=0 vga=current udev.log-priority=3 fastboot kaslr acpiphp.disable=1 i915.enable_guc_loading=1 i915.enable_guc_submission=1" – WinEunuuchs2Unix Jun 25 '18 at 4:33
  • 1
    18.04 transition is twice as good as 16.04. I'm researching why. The best transition happens with Grub to Windows 10. I've made a video of that but need to convert to GIF to fit within Stack Exchange 2 MB limit. I'm also researching Grub "theming" where reportedly you leave splash off but the background image stays up from the theme until login. Finally there is systemd Plymouth service for "smooth transition": wiki.archlinux.org/index.php/plymouth#Smooth_transition All this will take awhile... – WinEunuuchs2Unix Jun 27 '18 at 2:04
  • 1
    @Jazz Did you run sudo grub-update since making the proposed changes? – Dawoodjee Jun 27 '18 at 11:30
1
+250

You will always get a black screen between Plymouth and Login, unless you are using Windows 10. For myself in Ubuntu 16.04 it lasts about four seconds. In Ubuntu 18.04 it only lasts 1 or 2 seconds. You can however eliminate all text that appears on that screen.

There are a number of different things you can do for a smoother boot experience:

  1. Reduce console messages
  2. Reduce screen resetting
  3. Eliminate Grub messages
  4. Reduce fsck during boot

I've purchased a tripod for my cellphone to make videos of the various grub booting scenarios but have run into technical difficulties creating GIF to post here.

1. Reduce console messages

Based on Arch Linux's Silent Boot article you can add three extra options after quiet splash boot parameters:

quiet splash loglevel=0 vga=current udev.log-priority=3

The full article references systemd in boot in which case this can be used:

quiet loglevel=3 rd.systemd.show_status=auto rd.udev.log_priority=3
  • Also touch ~/.hushlogin to remove the Last login message.

2. Reduce screen resetting

From this Q&A: What is vt.handoff=7 parameter in grub.cfg? it says:

For a smooth boot process, we want to display something other than a black screen as early as possible and leave it on screen until the desktop is ready. vt.handoff=7 is part of this. We have the boot loader display an aubergine background (we wanted to have an Ubuntu logo as well, but there are problems with different aspect ratios between the boot loader and the real system, so this is the next best thing). vt.handoff=7 then causes the kernel to maintain the current contents of video memory on virtual terminal 7, which is a new "transparent" VT type. The first time that the kernel is told to switch away from VT 7, either from Plymouth or manually (Alt-F1, etc.), these contents are lost and VT 7 reverts to text mode.

If you are grub with a graphics background image add these lines in /etc/default/grub:

GRUB_GFXMODE="1920x1080x32"
GRUB_GFXPAYLOAD_LINUX="keep"

3. Eliminate Grub messages

After selecting a menu option, or the countdown timer expires grub sometimes issues these messages:

Loading Linux %s ..." ${version}
Loading initial ramdisk ...

To eliminate these message edit /etc/grub.d/10_linux and change these lines to comments:

# June 29, 2018 hide Loading Linux message
#  if [ x"$quiet_boot" = x0 ] || [ x"$type" != xsimple ]; then
#    message="$(gettext_printf "Loading Linux %s ..." ${version})"
#    sed "s/^/$submenu_indentation/" << EOF
#   echo    '$(echo "$message" | grub_quote)'
#EOF
#  fi

And a page down these lines too:

# June 29, 2018 hide Loading inital ramdisk message
#    if [ x"$quiet_boot" = x0 ] || [ x"$type" != xsimple ]; then
#      message="$(gettext_printf "Loading initial ramdisk ...")"
#      sed "s/^/$submenu_indentation/" << EOF
#   echo    '$(echo "$message" | grub_quote)'
#EOF
#    fi

4. Reduce fsck during boot

In your /etc/fstab ensure passno is set to 0 to prevent systemd-fsck@.service from running. More details from the manpage.

Change the frequency of fsck to every 30 boots or once a month: My Ubuntu is running fsck on every bootup

  • Thanks for all the effort. As you say, these seem to be all the things we can do to make it better. It has helped me gain an improved understanding of what is happening and why. – Jazz Jun 30 '18 at 22:02
  • @Jazz You're most welcome. It was certainly challenging. There was a great benefit to me though as I now have a nifty graphical grub theme setup with spinning countdown timer, menu icons for Ubuntu and a snazzy grub background. I will update this answer with images later. Of course thank you for the bounty too! – WinEunuuchs2Unix Jun 30 '18 at 22:10
-1

fsck is run by default by the initramfs. By removing it and having systemd run fsck you will be able to redirect the output.

systemd-fsck-root.service and systemd-fsck@.service located in /lib/systemd/system will need to be copied to /etc/systemd/system/ and edit them, configuring StandardOutput and StandardError like this::

[Service]

Type=oneshot
RemainAfterExit=yes
ExecStart=/usr/lib/systemd/systemd-fsck
StandardOutput=null
StandardError=journal+console
TimeoutSec=0

Your question has already been answered on Ask Ubuntu Here

  • It's not just fsck that shows up (as noted above) it's lots of other log messages as well, the fsck output was just an example (perhaps the one that shows up most often). Also your link about loglevels and quiet is about solutions that have also been tried - again see above) and it does NOT work to stop this problem – Jazz Jun 30 '18 at 11:31

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.