0

Though this is a common problem, none of the online solutions worked for me.

What I did:

  1. Fresh install of Ubuntu 16.04 (System76 Oryx Pro)
  2. Installed NVIDIA drivers (Tried, 390, 387, 384, system76-default drivers). I tried the .run file as well as the apt-get install nvidia-current (In separate installation attempts)
  3. I installed the driver virtually after disabling lightdm. After installation I login and it fails.

List of things I tried that didn't work:

1) Moved .Xauthority to .Xauthority.bak and logging in..

2) Created a blacklist file with the content, /etc/modprobe.d/blacklist-nouveau.conf, with the content : blacklist nouveau options nouveau modeset=0

3) Killed Xserver before installing NVIDIA

4) lsmod | grep nvidia , doesn't show nouveau, which means that nouveau isn't running causing a conflict.

5) I updated the linux kernel image to the latest (4.13.0-45-generic). I also tried an older 4.4.0-128-generic image. Both didn't work

6) Uninstalled lightdm, and installed gdm, didn't work.

1

After struggling with login loop for 3 days on Ubuntu 16.04 I changed to Ubuntu 17.10 and all issues related to login loop have gone. So I highly recommend to uninstall your current version and install Ubuntu 17.10.

Hope this helps.

  • I will try this as a last resort if nothing else works. Thanks! – mystique Jun 21 '18 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.