0

Trying to run sudo apt-get update, or almost any apt command, results in a core dump. The error message doesn't give much more than that:

Hit:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                   
Get:3 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]    
Get:4 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]  
Hit:5 http://ppa.launchpad.net/gnome-terminator/ppa/ubuntu xenial InRelease    
Hit:6 http://dl.google.com/linux/chrome/deb stable Release                     
Hit:7 https://dl.yarnpkg.com/debian stable InRelease                           
Get:8 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
Get:9 https://download.docker.com/linux/ubuntu xenial InRelease [65.8 kB]
Hit:10 https://deb.nodesource.com/node_8.x xenial InRelease                    
Fetched 389 kB in 0s (394 kB/s)
[1]    4498 abort (core dumped)  sudo apt-get update

I've looked for answers here and elsewhere, and almost every proposed solution involves running another apt-get command, like apt-get purge. Unfortunately, all of those commands result in similar core dumped errors.

Also of note, apport crashes when it tries to report the error. The window just dies when it's trying to show more information than the executable path. I get a string of apport messages when I first boot the system, all for apt or graphical software programs, like Gnome Software, and apport itself. I think the issue could be deeper than just apt.

I've tried looking for disk issues with badblocks, fsck, and G-Parted, but everything turns up clean. I seem to have plenty of disk space, memory, and CPU for what it's trying to do. I've tried to do more in depth analysis, but not being able to install utilities with apt-get makes it challenging.

I'm running Ubuntu 16.04 LTS 64-bit in a VMware Workstation 14 Pro VM. Unfortunately I was a fool who did not snapshot regularly, and I would prefer not to create a fresh VM since it would take some time to get my workspace back to how I like it.

2

Try this:

  • Delete all package lists and download them again

    sudo rm /var/lib/apt/lists/* -vf
    sudo apt-get clean
    sudo apt-get update
    
  • Edit: Finally, the solution from here worked.

  • Thanks for the response. clean will run, but update still gives me a coredup. It just runs more Gets before it dies after I delete the apt lists. – kallenboone Jun 19 '18 at 19:28
  • From this thread: purging libappstream3 or something similar that executes during an apt update might help? – Gavin Jun 20 '18 at 1:15
  • Thanks for that link! I couldn't purge libappstream3 because apt-get purge also core dumped, but when I tried to run dpkg -l '*libappstream*, I got an error. I Googled that error and found this: askubuntu.com/questions/343616/… I restored the backup dpkg status, and it all works now. – kallenboone Jun 20 '18 at 16:36
  • @kallenboone Don't forget to accept the answer by clicking check mark beside it. I'll upvote the answer based on your comment. – WinEunuuchs2Unix Jun 21 '18 at 0:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.