0

Have a 500GB SSD attached by USB, in NTFS format made by Windows Server 2012. I want to copy the contents of a folder (and subfolders) on sda2 called myfiles to the folder /opt/myapplic/myfiles on the primary drive. currently /dev/sdb

sudo fdisk -l 

shows it as /dev/sda1

So I did

sudo mkdir /media/external
sudo mount -t ntfs-3g -ro /dev/sda2 /media/external

and get the error

can't find /media/external in /etc/fstab

1
  • If the device is /dev/sda1 why do you mount /dev/sda2? Apart from this, please edit the question and be more specific with the error you receive (just copy-paste the command you run and the whole answer you receive) and use code formatting! – velix Jun 19 '18 at 15:14
1

The written mount command have some mistakes

You want to mount readonly ?

sudo mount -t ntfs-3g -r /dev/sda2 /media/external

You want to mount read/write

sudo mount -t ntfs-3g -o rw /dev/sda2 /media/external
1
  • A more detailed explanation: mount interprets -ro in the same way as -r -o (whose meaning you can look up in the manual). This is a common behaviour of command-line tools: “short” options that expect no arguments may be directly followed by other “short” options. – David Foerster Jun 19 '18 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.