0

Hi all (I'm new to ubuntu),

I want to install ANTs (https://github.com/ANTsX/ANTs/wiki/Compiling-ANTs-on-Linux-and-Mac-OS) on ubuntu 16.04 LTS which results in: CMake 3.10.2 or higher is required. You are running version 3.5.1

I've installed cmake 3.11.4, the output of cmake -version results in 3.11.4, but doesn't install ccmake.

Therefore I did sudo apt install cmake-curses-gui which gives me ccmake 3.5.1...

Can someone please help me how to update to ccmake 3.10.2 or higher on ubuntu 16.04 LTS? I'd appreciate any help. I also tried to install cmake with sudo make all but it didn't install ccmake 3.11.4.

Edit:

I used ./bootstrap && make && make install with sudo, after that I also tried it with make all.

I'd appreciate any help, best regards, Lucius

  • which command do you use when you said I've installed cmake 3.11.4, the output of cmake -version results in 3.11.4, but doesn't install ccmake. ? It can help a lot to find an answer – damadam Jun 19 '18 at 9:31
  • I used ./bootstrap && make && make install with sudo, after that I also tried it with make all – Luc Jun 19 '18 at 9:50
  • please edit your question by adding this command line, it will help others members than me (because I'm not the better place to answer) – damadam Jun 19 '18 at 9:52
  • It doesn't look like ccmake is really necessary - it's just used to create an initial configuration and possibly to set SuperBuild_ANTS_USE_GIT_PROTOCOL to OFF, which you could likely do just as easily using cmake -DSuperBuild_ANTS_USE_GIT_PROTOCOL=OFF ~/code/ANTs – steeldriver Jun 19 '18 at 11:39
  • @steeldriver thank you very much for that working workaround, alltough it doesn't solve the ccmake update problem... – Luc Jun 19 '18 at 13:36
1

I ran into the exact same issue while trying to compile ANTs pulled from Github on Ubuntu 16.04. Here is what I tried that worked for me:

  1. Remove cmake and cmake-curses-gui packages from Ubuntu: sudo apt remove --purge cmake.
  2. Download CMake from https://cmake.org/download/; I downloaded version 3.11.4 to ~/Downloads
  3. Install CMake v3.11.4: cd ~/Downloads tar zxvf cmake-3.11.4.tar.gz cd cmake-3.11.4 sudo ./bootstrap && make sudo make install make install requires sudo permission, but the sudo doesn't seem to propogate when multiple commands are connected by the && operator? So I ran make install separately.
  4. Verify that I've installed CMake v3.11.4: $ which cmake /usr/local/bin/cmake $ cmake --version cmake version 3.11.4 CMake suite maintained and supported by Kitware (kitware.com/cmake).
  5. To compile ANTs, I followed @steeldriver's comment and didn't use ccmake. Instead, I did this: mkdir -p ~/bin/ants cd ~/bin/ants cmake ~/Github/ANTs make (I didn't set the environment variable DSuperBuild_ANTS_USE_GIT_PROTOCOL=OFF.)

ANTs just finished compiling and didn't give me the CMake 3.10.2 or higher is required. error anymore. Basically I got around this problem by not using ccmake at all. Hope this helps!

  • Thanks for your detailed answer, I'm sure it will help other users encountering that problem as well. – Luc Jun 26 '18 at 7:53
0

I just compiled the latest cmake (in order to compile ANTs) on both CentOS 6 and Ubuntu 16.04. The build process for cmake will only create ccmake if it can find the ncurses dev files. For CentOS 6 you need to install ncurses-devel and Ubuntu 16.04 you need to install libncurses5-dev and libncursesw5-dev. After I did this, the "make" process for cmake created ccmake and I was able to build ANTs according to the instructions.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.