1

It seems pretty random. Sometimes there is not even a detection of an audio device after reboot. Other times I can hear the drums at bootup but there is no sound while using the system. I am able to see the device in the settings menu however. But I cannot play a test sound either.

This is what I tried so far:

  1. Force reload Alsa by sudo alsa force-reload reboot.
  2. Reinstalling Alsa and Pulsaudio by

    sudo apt-get remove --purge alsa-base pulseaudio
    sudo apt-get install alsa-base pulseaudio
    sudo alsa force-reload
    
  3. lspci -v | grep -A7 -i "audio" shows:

    00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)
        Subsystem: Dell Device 0786
        Flags: bus master, fast devsel, latency 32, IRQ 16
        Memory at d1228000 (64-bit, non-prefetchable) [size=16K]
        Memory at d1200000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
    
  4. aplay -l shows:

    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: PCH [HDA Intel PCH], Gerät 0: ALC3246 Analog [ALC3246 Analog]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    Karte 0: PCH [HDA Intel PCH], Gerät 3: HDMI 0 [HDMI 0]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    Karte 0: PCH [HDA Intel PCH], Gerät 7: HDMI 1 [HDMI 1]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    Karte 0: PCH [HDA Intel PCH], Gerät 8: HDMI 2 [HDMI 2]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    
  5. pactl list short sinks shows:

    2   alsa_output.pci-0000_00_1f.3.hdmi-stereo    module-alsa-card.c  s16le 2ch 48000Hz   SUSPENDED
    
  • the random issue, I already know that but with my touchpad, I never find what was the problem on it – damadam Jun 19 '18 at 9:14
  • Does this occur on a dual-boot set-up with Windows? Some audio chipsets are known to not work in Linux if Windows is in hibernation. – David Foerster Jun 19 '18 at 10:08
  • No dualboot. Only Ubuntu 16.04. I always had problems with my headphones. Plugging in headphones led to system crash. But all of a sudden I can't hear any sound at all besides the drums at bootup. – Zwenn Jun 19 '18 at 16:14
  • Yesterday it even worked again for a short moment after several reboots. But it was pretty quiet then and I couldn't change the volume. – Zwenn Jun 19 '18 at 16:22
0

You should open a terminal by pressing Ctrl+Alt+T and type:

alsamixer    

If you press the F6 key you should see the sound card (If action keys are enables in your BIOS/EFI firmware you might have to press Fn+F6)

you will now see 3 options:

  • (default)
  • 0 HDA Intel PCH
  • enter device name

[Note prom editor]: unclear what you're trying to accomplish here. Please adapt this section if I press esc key and then look into the system information I hold function the fn key and press f2 I can use the arrow keys to look at the /proc/asound/cards pressing return/enter I see two lines of information.

It could, if you write these two line into the text input with that device name in fn f6 select soundcard.
[End note]

Then exit alsamixer and type:

sudo apt-get update   
sudo alsa force-reload   
  • Thanks for your advice. Seems like there is nothing clicked off here. Tried to disable the auto-mute-mode but that didn't do anything. – Zwenn Jun 19 '18 at 16:18
  • Nope. This doesn't work for me. If I try to enter the two lines: HDA-Intel - HDA Intel HDA Intel PCH at 0xd1228000 irq 282 into the device name field I akways get the error : File or folder not found. – Zwenn Jun 20 '18 at 14:09
  • Plutesci Could you please review my edits and also review the editing help to improve the readability of your questions in the future... ;-) – Fabby Jul 1 '18 at 10:04
  • Fabby is that it?, I'm new here so not 100% sure on how to do that. – plutesci Jul 1 '18 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.