1

If I use the kernel that came with ubuntu 18.04 after a fresh-install, I can use the nvidia GPU.

However, after using ukuu to install kernel 4.17.2 I can't use the nvidia GPU anymore.

lucas@test:/boot$ uname -a
Linux test 4.17.2-041702-generic #201806160433 SMP Sat Jun 16 08:35:37 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

lucas@test:~$ prime-select query
nvidia

lucas@test:~$ glxinfo|egrep "OpenGL vendor|OpenGL renderer"
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 

When running nvidia-settings I get to see:

ERROR: NVIDIA driver is not loaded
ERROR: Error querying enabled displays on GPU 0 (Missing Extension).
ERROR: Error querying connected displays on GPU 0 (Missing Extension).

** Message: 20:49:20.826: PRIME: Requires offloading
** Message: 20:49:20.826: PRIME: is it supported? yes

ERROR: nvidia-settings could not find the registry key file. This file should
       have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

Interestingly, there is no /usr/share/nvidia/nvidia-application-profiles-key-documentation but a nvidia-application-profiles-390.48-key-documentation.

lucas@test:/usr/share/nvidia$ ls -l
total 16
-rw-r--r-- 1 root root 6041 mar 22 03:47 nvidia-application-profiles-390.48-key-documentation
-rw-r--r-- 1 root root 6052 mar 22 03:47 nvidia-application-profiles-390.48-rc

Everything is solved if -at boot time- I go choose kernel 4.15.0-22.generic, which is the kernel that came with the fresh install.

What can I do?

Thanks!

  • reinstall ubuntu – Egon Stetmann. Jun 19 '18 at 0:00
  • 1
    There is a chance that the drivers are not tested for that kernel yet and may not work. You can go to the /usr/src/nvidia-39x-39x.xx folder and run the make from that folder to try to build the drivers for that kernel as well. – Terrance Jun 19 '18 at 0:16
  • 1
    I guess it is not enabled then. As far as I can tell then the driver just may not be compatible with that kernel version yet. I was reading up on the ukuu is to install the newer / newest kernels, but as testing purposes only. – Terrance Jul 6 '18 at 5:06
  • 1
    I was experiencing frozen screens presumably from bugs in the nouveau driver, when I noticed that ending my routine custom kernel build with 'sudo apt install --reinstall nvidia-3xx' wasn't, in fact, guaranteeing that the nvidia module would be installed and be working after a reboot. So I arrived at this page and others, tried blacklisting nouveau, which did nothing, then noticed that the naming had changed for the nvidia drivers and that the next version was called 'nvidia-driver-396'. So, I tried installing that (which removed nvidia-390), and, bingo, I'm running with nvidia drivers again – Kim Phillips Aug 22 '18 at 20:33
  • 1
    apt install nvidia-driver-396? It automatically knew to replace nvidia-390 with it, so it automatically removed nvidia-390. I just checked, I don't have any special ppa's in my apt sources-list, so nvidia-driver-396 should be available to you and other Ubuntu 18.04 users. BTW, the versions of the custom kernel I was using were various stable releases of 4.16 and 4.17. – Kim Phillips Aug 24 '18 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.