1

The problem

Desktop PC freezes completely at BIOS boot up when trying to boot from Ubuntu 18.04 LTS USB stick.

How I made the USB

Using Startup Disc Creator application which comes installed by default in Ubuntu Gnome 16.04.4 LTS (laptop) and ElementaryOS Loki (desktop in question).

Other things I've tried

  • Booting from Ubuntu Gnome 16.04 LTS and 14.04 LTS also freezes at boot up.
  • Creating the Ubuntu 18.04 LTS USB stick with UNetbootin but also fails. However, it doesn't freezes, it just reports "Missing Operating System".
  • Booting from ElementaryOS Loki USB stick. It works!
  • Using GParted to compare how the USB was formatted by Startup Disc Creator with the Ubuntu 18.04 LTS and ElementaryOS Loki.

With Ubuntu 18.04 LTS made with Startup Disc Creator:

|Partition   |File system |Size        |Used        |Unused      |Flags      |
|------------|------------|------------|------------|------------|-----------|
|/dev/sdc1   |unknown     |4.00 KiB GiB|         ---|         ---|           |
|------------|------------|------------|------------|------------|-----------|
|unallocated |unallocated |1.75 GiB    |         ---|         ---|           |
|------------|------------|------------|------------|------------|-----------|
|/dev/sdc2   |fat16       |2.28 MiB    |2.26 MiB    |20.00 KiB   |           |
|------------|------------|------------|------------|------------|-----------|
|unallocated |unallocated |27.31 GiB   |         ---|         ---|           |
|------------|------------|------------|------------|------------|-----------|

With ElementaryOS Loki made with Startup Disc Creator:

|Partition   |File system |Size        |Used        |Unused      |Flags      |
|------------|------------|------------|------------|------------|-----------|
|unallocated |unallocated |2.62MiB     |         ---|         ---|           |
|------------|------------|------------|------------|------------|-----------|
|/dev/sdc2   |fat16       |2.28 MiB    |2.25 MiB    |28.00 KiB   |esp        |
|------------|------------|------------|------------|------------|-----------|
|unallocated |unallocated |7.26 GiB    |         ---|         ---|           |
|------------|------------|------------|------------|------------|-----------|

With Ubuntu 18.04 LTS made with UNetbootin:

|Partition   |File system |Size        |Used        |Unused      |Flags      |
|------------|------------|------------|------------|------------|-----------|
|/dev/sdc1   |fat32       |7.22 GiB    |1.85 GiB    |5.37 GiB    |           |
|------------|------------|------------|------------|------------|-----------|

Possible cause(s)

The problem seems to be related to how the USB is formatted. I'm suspecting it has something to do with the flags. While the ElementaryOS Loki live-usb made with Startup Disc Creator has a partition flagged as esp, the Ubuntu 18.04 LTS one made with either Startup Disc Creator or UNetbootin doesn't. I think it should be flagged as boot but I'm not sure since the ElemntaryOS one has esp, which I'm not even sure what it means.

Questioon

¿Should it be flagged as boot? And if so, why is not being flagged automatically?

Other details

  • Gigabyte GA-EX58-UD5 motherboard
  • BIOS F7
  • Sony 8GB USB
  • Kingston DTmicroDuo 8GB

Any help would be much appreciated!

  • I was able to make the Ubuntu 18.04 LTS live USB stick work by creating it with UNetbootin and then flagging the partition as boot with GParted. I will leave the question open, however, because I would like to know why this is not being done automatically by UNetbootin and why it's not even being formatted properly by Startup Disc Creator. Thanks! – Andrés Angelini Jun 18 '18 at 23:30
  • 1
    Is system UEFI or BIOS? While FAT16 is allowed on external devices with UEFI, it normally is FAT32. And has the ESP flag which is also boot with UEFI. Grub (BIOS boot) does not use boot flag (Windows does, as does the old Lilo boot loader and syslinux which the installer normally uses for BIOS boot), but some systems will not boot without a boot flag on some partition. ESP - efi system partition. Normally FAT32 on internal drives with boot flag and esp flag if separate. Normally just boot flag required. – oldfred Jun 18 '18 at 23:31
  • Hi @oldfred. Sorry, I forgot to mention that it's BIOS (it's a 10 years old motherboard). I think this might be the answer: "some systems will not boot without a boot flag on some partition." By the way, l also forgot to mention that Gparted give me warnings about not being able to detect the size properly with the Ubuntu 18.04 LTS live USB made with Startup Disc Creator. Thanks! – Andrés Angelini Jun 18 '18 at 23:47
  • @oldfred, I think your comment has answered my question, so you might want to convert it to an answer so that I can mark it as the best one. Or we can wait to see if anybody else has something else to add. Either way, thanks a lot! I've been struggling with this problem for days. – Andrés Angelini Jun 19 '18 at 0:00
1

Ubuntu Startup Disk Creator

In Ubuntu 16.04 LTS and newer versions, the Ubuntu Startup Disk Creator is a very robust cloning tool, which simply makes an exact copy from the iso file to the USB pendrive. This makes a USB boot drive, that works in most PC computers.

In older Ubuntu versions (for example Ubuntu 14.04 LTS), there are buggy versions of the Ubuntu Startup Disk Creator. It is better to use some other tool to create a USB boot drive.

This particular case

I agree that this might be the answer (originally explained by @oldfred).

I forgot to mention that it's BIOS (it's a 10 years old motherboard). I think this might be the answer: "some systems will not boot without a boot flag on some partition."

My experience makes me guess that you might have an HP computer. But there might be other brands, that need a boot flag, where other computers won't need it to boot.

  • Please tell us the brand name and model of the computer/motherboard and BIOS system. It is useful information for other people with the same or similar problems.

If this is the problem, you might succeed, if you

  • use mkusb to make a persistent live drive and
  • select an msdos partition table (instead of the default gpt)

mkusb creates a persistent live drive, that boots via grub also in BIOS mode. You can boot such a [USB pen] drive live-only, if you do not want or need persistence. I can boot HP computers, that are approximately 10 years old this way.

Please test mkusb, if you have the time

If you have the time, please test a persistent live drive by mkusb and share the result.

If you run standard Ubuntu live, you need an extra instruction to get the repository Universe. (Kubuntu, Lubuntu ... Xubuntu have the repository Universe activated automatically.)

sudo add-apt-repository universe  # only for standard Ubuntu

sudo add-apt-repository ppa:mkusb/ppa  # and press Enter
sudo apt-get update
sudo apt-get install mkusb mkusb-nox usb-pack-efi

Link to mkusb

  • That's a lot of information. Thanks @sudodus! I also added the motherboard model and BIOS version in "Other details" as requested. It's not an HP computer. I built it myself back then but it might be useful to know for those who own one. I also added from which OSes I've tried making the live usb with Startup Disc Creator. I haven't had the time to try mkusb yet but I'll let you know when I do. Hope it helps! – Andrés Angelini Jun 20 '18 at 16:40
  • @AndrésAngelini, 1. Thanks for the data about the motherboard and BIOS. I have no own experience (of that motherboard), but I think the information will be useful for several people; 2. I think the USB boot drives are good (made with a robust version of the Ubuntu Startup Disk Creator); 3. I'm looking forward to your results with mkusb :-) – sudodus Jun 20 '18 at 16:50
  • Hi @sudodus! I finally got the time to test mkusb. Bare in mind I did some things a little bit different. Apparently, I didn't need to add universe and I didn't install either mkusb-nox nor usb-pack-efi. I'm not sure what the first one is and I'm not making a persistent drive so the second wasn't necessary in my case. Unfortunately, the results were the same as the ones with Ubuntu 18.04 LTS stick made with Startup Disc Creator (first table). It froze completely and it's missing the boot flag. Also, it has four partitions. – Andrés Angelini Jun 22 '18 at 21:43
  • 1
    It works perfectly by making a persistent live drive with Ubuntu 18.04 LTS iso using mkusb with usb-pack-efi and then booting it as live-only! On a closer inspection with GParted, I noticed it created 6 partitions with the one formatted as fat32 flagged as boot. So, making the live-usb drive as persistent even if you don't need to might be the most straightforward solution for a regular user who is experiencing this issue. Am I wrong? – Andrés Angelini Jun 23 '18 at 19:39
  • 1
    That's a great insight, @sudodus. And now that I think about it, the ElementaryOS Loki iso does boot without any hiccups in my desktop pc, which means this could (or should) be solved at the iso level. Perhaps, then, I should file a bug to Ubuntu itself. I feel like I should be doing something to let the developers know the installation iso is not working for some of us. – Andrés Angelini Jun 28 '18 at 13:00
2

With BIOS based systems grub does not use Boot flag. But some BIOS must assume Windows and will not boot without some partition having a boot flag on a primary partition. Windows requires a boot flag on a primary NTFS formatted partition to boot.

Live installer in BIOS mode is FAT32 (normally) and needs boot flag on that partition. Some tools (like dd) when used to create live installer, use different methods to create live installer and then it may not look like standard partitions. Not sure which versions, create which type of view from gparted or partition lists.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.