2

complete noob here, trying to update from 16.04 to 18.04 - but I'm facing an error with my package manager. Even running sudo apt-get install -f (after going through a few suggestions I found) results in this error:

Errors were encountered while processing: /var/cache/apt/archives/snapd_2.32.9_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

Any clues on what I can do to fix this?

Thank you!

edit - adding full output of sudo apt-get install -f:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libgtkmm-2.4-1v5 linux-headers-4.13.0-36 linux-headers-4.13.0-36-generic
  linux-headers-4.4.0-117 linux-headers-4.4.0-117-generic
  linux-headers-generic-lts-xenial linux-image-4.13.0-36-generic
  linux-image-4.4.0-117-generic linux-image-extra-4.13.0-36-generic
  linux-image-extra-4.4.0-117-generic linux-image-generic-lts-xenial
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  snapd
The following packages will be upgraded:
  snapd
1 upgraded, 0 newly installed, 0 to remove and 147 not upgraded.
35 not fully installed or removed.
Need to get 0 B/14,2 MB of archives.
After this operation, 2 478 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 321112 files and directories currently installed.)
Preparing to unpack .../snapd_2.33~14.04_amd64.deb ...
Failed to stop snapd.autoimport.service: Unit snapd.autoimport.service not loaded.
Failed to stop snapd.socket: Unit snapd.socket not loaded.
Failed to stop snapd.service: Unit snapd.service not loaded.
dpkg: warning: subprocess old pre-removal script returned error exit status 5
dpkg: trying script from the new package instead ...
Failed to stop snapd.autoimport.service: Unit snapd.autoimport.service not loaded.
Failed to stop snapd.socket: Unit snapd.socket not loaded.
Failed to stop snapd.service: Unit snapd.service not loaded.
dpkg: error processing archive /var/cache/apt/archives/snapd_2.33~14.04_amd64.deb (--unpack):
 subprocess new pre-removal script returned error exit status 5
Errors were encountered while processing:
 /var/cache/apt/archives/snapd_2.33~14.04_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • For error code 1 handling, we need to know if its post processing or preprocessing. Paste more log information. – cmak.fr Jun 18 '18 at 20:01
  • Thanks! Where can I find that? Should I simply paste the /var/crash output? The crash report is giving me this: package snapd 2.31.2-14.04 failed to install/upgrade:subprocess new pre-removal script returned error exit status 5 – dlsantos Jun 19 '18 at 18:56
  • Trying to upgrade gives me this: The following packages have unmet dependencies: ubuntu-core-launcher : Depends: snapd (= 2.33~14.04) but 2.31.2~14.04 is installed. E: Unmet dependencies. Try using -f. – dlsantos Jun 19 '18 at 19:04
  • please edit your post to paste all the output of sudo apt-get install -f formatted with {} – cmak.fr Jun 19 '18 at 20:27
0

You should be able to remove ubuntu-core-launcher as I don't believe it's required anymore.

sudo apt remove ubuntu-core-launcher

Which may progress your upgrades further.

| improve this answer | |
0

sudo apt remove ubuntu-core-launcher

also creates the following error

Reading package lists... Done Building dependency tree
Reading state information... Done Package 'ubuntu-core-launcher' is not installed, so not removed You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: default-jdk : Depends: openjdk-11-jdk but it is not going to be installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

any help plz

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.