9

In Ubuntu, I want to open a PDF document generated for Adobe Reader 10. Apparently the latest version which I can install is Adobe Reader 9.5.5. Is there a way to install version 10?

I installed Wine, but I don't know how to install acroread using Wine.

  • Both Chrome and Firefox usually include up-to-date Reader. Try opening the file in a web browser. – user535733 Jun 18 '18 at 18:44
5
+25

There are many decent pdf readers available for a Linux system these days, my own personal favourite being Okular. However if you are really keen it is still possible to install Adobe Reader X1 (version 11.0.08) under Ubuntu Xenial Xerus 16.04 using wine. It just takes a little bit of finesse :).

The following steps are required:

1. Install wine:

Run the following command in a Terminal window to install wine and a few extra applications:

sudo apt-get install wine cabextract p7zip unrar unzip wget zenity

Once this rather hefty download is done you will need to set a 32 bit prefix for wine to use, necessary for the Adobe Acrobat to work properly. First back up any default wine configuration and then create the prefix:

mv ~/.wine ~/.wine_bak
WINEARCH=win32 WINEPREFIX=~/.wine32 winecfg 

With winecfg open make sure that it is set to 'Windows XP', this has been tested as giving the best performance with the Acrobat Reader.

2. Update winetricks:

You will need to install the most modern version of winetricks. Use the following commands in a Terminal window to accomplish this:

sudo apt-get remove winetricks
wget  https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
chmod +x winetricks 
sudo mv -v winetricks /usr/local/bin

Then download a needed file with the following command, which you will note is using our new 32 bit wine prefix:

WINEARCH=win32 WINEPREFIX=~/.wine32 winetricks mspatcha

3. Download and install the reader:

Now to download the required reader with the following single command:

cd $HOME/Desktop && \
wget --progress=dot --tries=10 \
https://ardownload2.adobe.com/pub/adobe/reader/win/11.x/11.0.08/en_US/AdbeRdr11008_en_US.exe

and finally install the downloaded Reader to the wine 32 bit prefix directory

cd $HOME/Desktop && \
WINEARCH=win32 WINEPREFIX=~/.wine32 wine AdbeRdr11008_en_US.exe

4. Running the reader:

When the reader first loads select the option "Always open with Protected Mode Disabled" seen in the first screen. Then for the most part you should be set although I have not extensively tested all available options.

Below is a screenshot of the Acrobat Reader running on my own 16.04 system:

Adobe Acrobat on Ubuntu Linux

5. Cleaning up:

During the installation there are 2 extraneous files created which you can either ignore or delete:

  1. ~/.wine is needlessly created again, if you have no use for this run the following command:
    mv ~/.wine_bakk
  2. A non-functioning desktop link is created, remove this with the following command:
    rm "$HOME/Desktop/Adobe Reader XI.lnk"

Notes:

  • 6.5.3 How do I create a 32 bit wineprefix on a 64 bit system? Canonical information on how to set a 32 bit prefix on a 64 bit system.
  • How do I get the latest version of winetricks on Ubuntu? My own question and answer on updating winetricks which I have pillaged for this question!
  • Setting variables: Depending on your other usage of wine you could cement the variables used in this guide by placing the following variables in ~/.bashrc with your favourite text editor:

    export WINEPREFIX=~/.wine32
    export WINEARCH=win32
    

    and then running the command: source ~/.bashrc. I have left this advice in 'Notes' as this brief guide seemed complex enough already :).

2

Theoretically PDF is a portable open format so any compliant tool shall be able to let you open and process the files generated by Adobe Reader 10, even though Adobe no longer offers Reader on Linux.

Please review the following alternatives:

https://alternativeto.net/software/adobe-reader/?platform=linux

Personally I have a good experience with:

https://www.foxitsoftware.com/downloads/

however I found a few rare editable PDF forms that made Foxit Reader dump the core on you.

At the moment Evince provided by Ubuntu by default works well for me.

Anyway please let us know the results and your personal experience with various tools so other can learn from your experience.

  • Foxit is good but its Windows version certainly better. – Apoorv Potnis Jun 26 '18 at 2:36
2

Install Adobe Acrobat Reader DC on Ubuntu 18.04

This guide follows

sudo apt install wine-stable winetricks
winetricks mspatcha

Download acrobat reader from the hompage.

or use

wget https://ardownload2.adobe.com/pub/adobe/reader/win/AcrobatDC/1800920044/AcroRdrDC1800920044_en_US.exe

Install acrobat reader with wine

wine AcroRdrDC<insert your version>_en_US.exe

Start acrobat reader by searching it in your start menu

That's all!


Another Alternative

I personal like MasterPDF, which is also a good choice if you are using an unregistered version.

If you want to alter a pdf via command line, use pdftk since it is a well proven and good command--line tool.

  • I am getting this error trying to install acrobat according to your answer:Unhandled exception: unimplemented function msi.dll.MsiGetComponentPathExW called in 32-bit code (0x7b83935c). Register dump: CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b EIP:7b83935c ESP:0088caa4 EBP:0088cb28 EFLAGS:00200212( - -- I -A- - ) EAX:7b82694d EBX:00000004 ECX:0088cad0 EDX:0088cb50 ESI:7ebb8120 EDI:0088d1d8 Stack dump: Backtrace: – Dalek Jun 18 '18 at 19:21
  • Do you have a 64bit or 32bit machine, and which version did you download? – abu_bua Jun 18 '18 at 19:24
  • @Dalek: If you want a good pdf viewer install that from code-industry.net/free-pdf-editor. Download the linux version and install it with apt-get install ./name_of_download.deb. Works fine and even it is not a free version you can do a lot! – abu_bua Jun 18 '18 at 19:56
  • I have a 64bit machine. – Dalek Jun 18 '18 at 23:21
  • I need to open a pdf document in my browser and I have just linux on my machine while I get this message: If this message is not eventually replaced by the proper contents of the document, your PDF viewer may not be able to display this type of document. You can upgrade to the latest version of Adobe Reader for Windows®, Mac, or Linux® by visiting http://www.adobe.com/go/reader_download. but I am not able to install acroread 10 for linux and apparently that it what I need. any suggestion? – Dalek Jun 19 '18 at 16:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.