0

My lubuntu software updater seems to have troubles installing certain update packages.

After booting, it shows me the list of required updates, but when I try to install them, it terminates directly after showing the "Installing updates..." progress bar. Without any error message. Sometimes I can install the updates by randomly unchecking some packages from the list. So maybe there is a problem with some sources? Unfortunately I dont know much about Ubuntu. Also, with sudo apt-get update I can install some of the updates, but not all.

Is there a way to find out why this is happening? Or does anyone already know a solution?

Thanks!

EDIT: sudo apt-get update results in:

http: //security.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB] Hit:2 http: //archive.canonical.com/ubuntu bionic InRelease
Hit:3 http: //de.archive.ubuntu.com/ubuntu bionic InRelease
Hit:4 http: //ppa.launchpad.net/linrunner/thinkpad-extras/ubuntu bionic InRelease Hit:5 http://de.archive.ubuntu.com/ubuntu bionic-updates InRelease Hit:6 http://de.archive.ubuntu.com/ubuntu bionic-backports InRelease Ign:7 http://ppa.launchpad.net/upubuntu-com/ppa/ubuntu bionic InRelease
Err:8 http://ppa.launchpad.net/upubuntu-com/ppa/ubuntu bionic Release 404 Not Found [IP: 91.189.95.83 80] Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/upubuntu-com/ppa/ubuntu bionic Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.

sudo apt-get upgrade:

Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages were automatically installed and are no longer required:
linux-image-4.13.0-43-generic linux-image-extra-4.13.0-43-generic Use 'sudo apt autoremove' to remove them. The following packages have been kept back: configure-trackpoint:i386 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Note: I put some space in the links, as I am not allowed to post so many links...

  • @user535733 done :) there also seems to be a problem with the repositories... – Kuhkäfer Jun 18 '18 at 16:47
  • Problem #1: Dead source (Err:8 ppa.launchpad.net/upubuntu-com/ppa/ubuntu bionic Release 404 Not Found [IP: 91.189.95.83 80]). Remove the source – user535733 Jun 18 '18 at 17:45
  • Problem #2: Held package (The following packages have been kept back: configure-trackpoint:i386). Tell us everything you know about that package, and why you installed it. – user535733 Jun 18 '18 at 17:48
  • #1: Hmm I just tried to (with the Software & Updates GUI), but it doesnt react. Is there another way to remove the source? – Kuhkäfer Jun 18 '18 at 21:38
  • #2 I have a lenovo thinkpad with a trackpoint and tried to configure its speed. I a tutorial (long ago, I dont remember which one) I was asked to install it.... – Kuhkäfer Jun 18 '18 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.