3

I just did a fresh install of Ubuntu 18.04 and installed a ttf font (Didact Gothic) via the font manager.

However, this font isn't showing in libreoffice 6.0.

I allready tried rebooting program and pc, uninstalling and reïnstalling the font

Does anyone have a solution for this?

PS: It worked just fine on Ubuntu 16.04. PPS: It does work in libreoffice Calc 6.0, but not in writer 6.0.

1 Answer 1

1

It's a "snap" issue - if you use the "snap" version of Ubuntu, you will not be able to "see" any fonts you have installed in Ubuntu.

Close LibreOffice, if it is open.

Open Terminal - hold "Ctrl", "Alt" and press "T" - then enter:

sudo fc-cache -fv

Change your "working" directory - that is, where you are in Terminal - to that of LibreOffice:

cd ~/snap/libreoffice/current

Create a symbolic link ("shortcut") to your font folder:

ln -s /home/your-ubuntu-username/.local/share/fonts

Then run this command:

ln -s ~/.fonts .fonts

This should work (it did for me just then!) and I've tried to make it as easy to follow as possible - but you don't feel comfortable using Terminal commands, you can always switch to the "regular" version of LibreOffice...

Open Ubuntu Software and search for "libreoffice" - remove the one that has references to "snap" or "snapcraft.io" when you click on it (i.e. on the page that has the picture, description, etc...) - it should have these references under the "Details" section towards the bottom.

Hit the "back" arrow and install the "regular" version of the LibreOffice programs you need to use - these should not contain any references to "snap" or "snapcraft.io" under the "Details" section at the bottom.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .