2

I'm relatively new to Linux. I tried to install Virtualbox on Lubuntu 18.10. I had never used it before.

During the installation, a prompt told me that I had to alter my Secure Boot. I wasn't anticipating that and tried to discontinue the installation so I could read more about what that meant before moving forward.

I tried to uninstall Virtualbox using the Software application but it would not give me that option. I tried to use the Synaptic Package Manage to uninstall, but it prompted me to run sudo dpkg --configure -a in terminal. That did nothing for an indeterminate amount of time. I had to close out terminal entirely to write another command, and then I uninstalled Virtualbox using sudo apt-get --purge remove virtualbox and dpkg --list seemed to indicate this was successful.

But there still appears to be a residual problem that I can't discontinue. Synaptic still gives me the same prompt if I try to use it. So does dist-upgrade command when I tried it among other things. If I try sudo dpkg --configure -a now I still get a process that appears to freeze in terminal. I get this:

And then nothing more seems to happen. Task manager seems to indicate nothing is happening. I saw that this was addressed once before on this forum but those solutions did not seem to work for me in this case.

  • You could simply uninstall the virtualbox-dkms package.... – user535733 Jun 17 '18 at 22:51
  • Thank you. This worked. Because you answered this in the comments, not sure how to indicate this has been answered. I also needed to do the following first to get that to work: sudo rm /var/lib/dpkg/lock sudo rm /var/lib/apt/lists/lock sudo rm /var/cache/apt/archives/lock cd /var/lib/dpkg/updates sudo rm * – Absurdistan Jun 18 '18 at 0:53
  • Welcome to Ask Ubuntu! Could you please post text files, dialogue messages, and program output listings as text, not as images? To achieve the latter two you can either 1) select, copy & paste the dialogue text or terminal content or 2) save the program output to a file and use that. Longer listings (the editor will tell you what’s too long) should be uploaded to a pastie service and linked to in the question. Thanks. – David Foerster Jul 15 '18 at 10:56
  • If you solved your problem, please consider to answer your own question and accept your answer. Don’t put the answer in your question or the comments! :-) Thanks. – David Foerster Jul 15 '18 at 10:57
0

The above combination was what worked for me.

sudo rm /var/lib/dpkg/lock
sudo rm /var/lib/apt/lists/lock 
sudo rm /var/cache/apt/archives/lock 
cd /var/lib/dpkg/updates sudo rm *
sudo apt-get remove virtualbox-dkms

All credit goes to those that commented above.

| improve this answer | |
  • 1
    -1 for the recommendation of the indiscriminate removal of package manager lock files. – David Foerster Jul 15 '18 at 10:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.