I'm an UBUNTU beginner. I researched this topic and found this.
https:// askubuntu.com/q/1043930/828489

Tried the above solution but got an error on libpango:

[sudo] password for xxxxxx:

Canon Inkjet Printer Driver Version 3.90 Copyright CANON INC. 2001-2013 All Rights Reserved.

================================================== Command executed = sudo dpkg -iG ./packages/cnijfilter-common_3.90-1_amd64.deb Selecting previously unselected package cnijfilter-common. (Reading database ... 165328 files and directories currently installed.) Preparing to unpack .../cnijfilter-common_3.90-1_amd64.deb ... Unpacking cnijfilter-common (3.90-1) ... Setting up cnijfilter-common (3.90-1) ... Processing triggers for libc-bin (2.27-3ubuntu1) ... Command executed = sudo dpkg -iG ./packages/cnijfilter-mx920series_3.90-1_amd64.deb Selecting previously unselected package cnijfilter-mx920series. (Reading database ... 165346 files and directories currently installed.) Preparing to unpack .../cnijfilter-mx920series_3.90-1_amd64.deb ... Unpacking cnijfilter-mx920series (3.90-1) ... dpkg: dependency problems prevent configuration of cnijfilter-mx920series: cnijfilter-mx920series depends on libpango1.0-0 (>= 1.12.3); however: Package libpango1.0-0 is not installed.

dpkg: error processing package cnijfilter-mx920series (--install): dependency problems - leaving unconfigured Errors were encountered while processing: cnijfilter-mx920series Command executed = sudo dpkg -P cnijfilter-mx920series (Reading database ... 165544 files and directories currently installed.) Removing cnijfilter-mx920series (3.90-1) ... Purging configuration files for cnijfilter-mx920series (3.90-1) ... Processing triggers for libc-bin (2.27-3ubuntu1) ... Command executed = sudo dpkg -P cnijfilter-common (Reading database ... 165345 files and directories currently installed.) Removing cnijfilter-common (3.90-1) ... Purging configuration files for cnijfilter-common (3.90-1) ... Processing triggers for libc-bin (2.27-3ubuntu1) .

when I try

sudo apt-get install libpango-1.0-0

I get

Reading package lists... Done Building dependency tree Reading state information... Done libpango-1.0-0 is already the newest version (1.40.14-1). The following packages were automatically installed and are no longer required: libappindicator1 libindicator7 Use 'sudo apt autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 17 not fully installed or removed. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n]

Now Ubuntu sees a printer but when I print a document, Ubuntu thinks it printed, but the printer doesn't do anything.

Any suggestions?

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.