UPD: One of the problems is now fixed! The fix is at the end of this post.

I always try to google an answer without posting to forums myself, but now I am stuck with this problem for a few days.

I recently started using Ubuntu 18.04 LTS, and I need to install Steam.
Linux version of Steam works flawlessly for me, but I also need a Windows version for some non-Linux games.

I've downloaded 'SteamSetup.exe' from the official website. I am also using the latest version of Wine (development version).

After installing Windows version of Steam, I've got a problem with Steam's web browser. All the web pages (Store, Profile etc.) were just black and not loading. And when I try to install one of my games I get the 'Content servers unreachable' error. Steam itself (I mean GUI) works pretty fine, it just seems it cannot use its browser. And the 'Friends' window also works: I can see them being online and playing something.

After looking for a solution I found that I should use '-no-cef-sandbox'. After adding it Steam browser stopped loading completely showing 'invalid SSL certificate' error on all pages I tried to access.

After searching more I found that I should set my Wine to 'Windows XP'. So I opened winecfg and set it. And after this change it is in the state I am now. Now some pages load black and some pages load only some plain blue text in front of a black background (looks like some sort of HTML rendering error, but I don't know what really should I do to fix this), and a loading icon at the top-right corner is now glitched: it skips the whole animation cycle only showing its lighter part "jumping" at its top side. I've also noticed that the first time I try to load a page after launching Steam its browser's address bar turns green for a second (as if the connection is established), but then goes grey permanently. It was also red sometimes.

I've also tried these things (as you may understand, with no positive result):

  • Using non-development Wine release (I installed it first and then replaced it with a development one).
  • Messing around with fonts (e.g. mscorefonts), but it actually doesn't seem to help me, because all the texts were OK for me from the beginning.
  • Using PlayOnLinux produced the exact same result, and I removed it because I prefer using plain Wine.
  • Redownloading 'SteamSetup.exe' and reinstalling it.
  • Downloading Firefox and setting it to be a default browser instead of Chromium (I am using Chromium as the default and only browser).
  • Checking my time and date in Ubuntu and in BIOS (this was suggested to fix the 'Content servers unreachable' error, but my time and date settings seem to be correct in both).
  • Changing a download region in Steam settings.
  • Clearing cache and cookies in Steam settings.
  • Installing 'Steam for Windows' snap package instead of using 'SteamSetup.exe' (I hope I called it right, because I'm still not used to these snaps or something).
  • Opt into and out of Steam Beta. (In Steam Beta mode the 'Friends' window is not accessible, too.)

There may be something else I forgot to list here, and I am running out of ideas. And now I am here to ask for help. Hope to get a new advice. Please, help! Thanks in advance.

P.S.

As you see, I've got two problems here: the web browser not loading and the 'Content servers unreachable' error. I combine them here, because I believe they are related in my case, but in case they aren't... It will be good to fix them both, but right now all I actually need from the Windows version is downloading and launching some non-Linux games (for the other functionality I can just use the Linux version), and thus I need to fix the 'Content servers unreachable' in priority.

UPD: The 'Content servers unreachable' error can be easily fixed by copying the "CS" line from config.vdf in Linux version to the same place in Windows version. (The detailed explanation is in one of the answers below.)

  • a data point fyi - I have 18.04 and installed the default wine version then windows steam from their website. I have the all black webpage problem but the library works in small mode and games launch fine. I have Nvidia graphics. – Organic Marble Jun 17 at 18:33
up vote 3 down vote accepted

I managed to get the download started, browser is still not working but at least it installs the game.

Following procedure:

  • Install if you haven't so far, the Linux Steam Version and make sure it works.
  • open this file with your favorite text-editor: ~/.steam/steam/config/config.vdf
  • search for "CS" and copy the entire line
  • paste the line after the line starting with "cis" in file: ~/.wine/drive_c/Program Files (x86)/Steam/config/config.vdf

    or wherever you installed steam and restart.

  • Man, you are my hero! I successfully started downloading right now. Many thanks! Thus, the main problem is now fixed. A funny thing is I was literally half-a-step away from finding this solution two days ago. I did pretty much the same exact thing, but I was using the "CS" line from somebody else's forum post, but not from my own Linux version. Wow, it's fun to find out I was so close once earlier! – Dmitriy M. Jun 19 at 15:58
  • Now I'm wondering if the browser's issue can be fixed this way, too. Some lines of code may be missing for that one, too... – Dmitriy M. Jun 19 at 16:07
  • hey I can't find the line starting with "CS" in the ~/.wine/drive_c/Program Files (x86)/Steam/config/config.vdf file, so I can't even test your answer to see if it works. I'm having the same problems as the OP. I can find the "CS" line in the Linux Steam file, but not the Wine file. – Emandudeguy Jul 19 at 6:09
  • I edited your post to show the full instructions on how to fix steam. Pasting the "CS" line after the "cis" line in the wine config.vdf file works for me. – Emandudeguy Jul 25 at 5:35
  • Reposted from an answer by Jacob Davis: I had some trouble finding the specific location referenced in Peter's answer, and I found that if I pasted the line starting with "CS" from native Linux Steam into the same location in the conf file for Wine Steam (for me it was between the lines starting with "SentryFile" and "ConnectCache"), I was able to download games perfectly. – karel Jul 28 at 6:29

Delete any folders to do with Steam (Make sure you press Ctrl + H to show any hidden files. Make sure you search it as well) then go to the software and type Steam install Steam not Steam Installer.

  • What? 'Go to the software'? I guess you missed something in my question. We're speaking about Windows version of Steam, not the Linux one. – Dmitriy M. Jun 21 at 18:13
  • Btw, this is my own answer and has nothing to do with yours:) – YoureSOStubborn Jun 28 at 15:21
  • But if the answer is on Ask Ubuntu it's probally to do with Linux? – YoureSOStubborn Jun 28 at 15:22
  • Well, it actually is smth to do with Linux. I'm talking about using Windows apps on Linux here. – Dmitriy M. Jun 28 at 17:15

The browser issue is that the steam web based browser doesn't have both the digicert certificates installed. You need to import the intermediate certificate and the one that shows on the store.steampowered.Com site when you click on the lock symbol. It needs both.

  • Sounds like you know the fix I need, but can you, please, be more specific? How should I import those certificates? – Dmitriy M. Jun 21 at 18:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.