0

A few years ago I switched from Windows to Ubuntu 14.04 LTS for my desktop PC. I installed the Ubuntu operating system (root+home+swap) in the space previously assigned to the C partition, while the other partitions (D,E,F and G) were left undisturbed. Thus the partitions containing the new operating system now have the ext4 file system while the other partitions continue with ntfs. This has been serving my purpose well enough.

Recently, however, for the first time I made several attempts to run fsck on the ntfs partitions of the hard drive, and I received the following message:

fsck from util-linux 2.20.1
fsck: fsck.ntfs: not found
fsck: error 2 while executing fsck.ntfs for /dev/sda5

When I try to run fsck on my external hard drive, which also has ntfs, the message that is returned is:

fsck from util-linux 2.20.1
e2fsck 1.42.9 (4-Feb-2014)
ext2fs_open2: Bad magic number in super-block
fsck.ext2: Superblock invalid, trying backup blocks...
fsck.ext2: Bad magic number in super-block while trying to open /dev/sdb

And:

The superblock could not be read or does not describe a valid ext2/ext3/ext4 filesystem. If the device is valid and it really contains an ext2/ext3/ext4 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock: e2fsck -b 8193 or e2fsck -b 32768

Can anybody please throw any light on what is happening and how I can run fsck on ntfs partitions and devices?

0

1 Answer 1

0

First, ensure you have ntfs-3g installed.

You can try following the top answer from the below post by @Micro:

fsck.ntfs is usually only a link to ntfsfix which is an utility from the package ntfsprogs that is already available with a standard installation of Ubuntu.

You can make a simbolic link between fsck.ntfs and ntfsfix to solve this permanently:

sudo ln -s /usr/bin/ntfsfix /sbin/fsck.ntfs
sudo ln -s /usr/bin/ntfsfix /sbin/fsck.ntfs-3g

Keep in mind that this utility came from a reverse engineering process and are not the best option to manage your filesystem, the NTFS filesystem does not belong to the GNU/linux world.

Source: fsck can't find fsck.ntfs

Not the answer you're looking for? Browse other questions tagged or ask your own question.