2

I upgraded from 16.04 and then installed this https://flatpak.org/setup/Ubuntu/ - It works to find and install flatpaks from the ubuntu software center, but no flatpak app works to launch.

To give you an example of the error, here's what I get from Kdenlive:

tio@tio:~$ flatpak run org.kde.kdenlive
ERROR: ld.so: object 'libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Could not initialize GLX

I have Nvidia 396.24.02 installed. Thing is, if I switch to X.Org (Nouveau) they work just fine. Problem is, with X.Org I get a laggy desktop environment. So I understand that Flatpak doesn't like Nvidia? Is there any way to make these work with Nvidia?

I searched and searched and didn't find any answer.

EDIT: It seems the issue is with graphical tools like Kdenlive or Krita. Not with apps like Riot or Signal. I suppose the graphical tools need access to Nvidia and they can't find it?! I hope someone can help. Thanks!

EDIT 2: GIMP for example works. Riot works, Signal works, and most flatpak work. Kdenlive and Krita do not. Same error for both. Very strange.

EDIT 3: I have a better answer after investigating. It seems some packages were missing from the Nvidia install so I installed Kdelive from the flathub website: flatpak run org.kde.kdenlive. That installed some flatpak dependencies, and after Kdenlive was successfully installed all the other apps that didn't work, worked again.

  • did you try running it as root or changing the owner and permitions of .nv in your home folder ? – Yvain Jun 24 '18 at 0:31
  • @Yvain as root is the same flatpak run org.kde.kdenlive libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swrast Could not initialize GLX – Tio TROM Jun 24 '18 at 0:37
  • 1
    .nv folder has User permission. What to change about it? I suppose running as root and still getting the same errors, it must be flatpak not recognizing nvidia 390 or 396 drivers? – Tio TROM Jun 24 '18 at 0:38
  • ok then, go to the setting gui and see if the used driver is indeed your nvidia driver in sofwares and update – Yvain Jun 24 '18 at 0:44
  • if not change that, if yes try purging all nvidia files with apt-get purge nvidia* bbswitch* and reinstall, also beware depending on your model the latests nvidia drivers will not work and you don't get an xsession. – Yvain Jun 24 '18 at 0:50
0

Short answer: Use the command line interface to install applications, the software center doesn't work.

It works to find and install flatpaks from the ubuntu software center

The version of gnome-software-plugin-flatpak provided by Ubuntu 18.04 doesn't work properly. For some reason it doesn't install extensions (like codecs, locales, themes or drivers) required by the application.

Is there any way to make these work with Nvidia?

Yes, the extensions with the NVIDIA driver matching the version of your host driver must be installed. This should have been installed automatically, when you installed the application.

Bug Report: https://bugs.launchpad.net/ubuntu/+source/gnome-software/+bug/1809945

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.