8

Whenever I turn my bluetooth off from the settings menu, it's back on after reboot. I know this has already been asked but I've tried all answers that have been provided and nothing seems to work.

The most popular suggestion is: Run sudoedit /etc/rc.local and add this before line with exit 0:

rfkill block bluetooth

When I do this, an empty file opens up and it's not even rc.local if I'm correct. (see screenshot). I'm running Ubuntu 18.04 LTS.

Screenshot

If I run ls -l /etc/rc.local this comes up:

Screenshot2

If I run: sudo rfkill list all:

Screenshot3

I've tried everything in this link except installing BUM: How can I deactivate Bluetooth on system startup?

  • 2
    Well, what's the link to the other suggestions you tried ? Yes, the file in screenshot is a temp file, which is odd. Did you run sudoedit /etc/rc.local or did it differ somehow ? Does ls -l /etc/rc.local suggests it's a symlink ? – Sergiy Kolodyazhnyy Jun 16 '18 at 4:24
  • Also, sudo rfkill list all output would be nice to add – Sergiy Kolodyazhnyy Jun 16 '18 at 4:25
  • 1
    "When I do this, an empty file opens up and it's not even rc.local if I'm correct. " Yes it is. Custom method in Linux: editing a file in use is bad practice, so a file in /tmp/ is created and mv to the place it needs to be. Next: you did not find anything on blacklisting the bt module?! I find that odd ;) – Rinzwind Jun 16 '18 at 9:45
  • I've tried everything in this link except installing BUM: askubuntu.com/questions/67758/… – Lucy C Jun 17 '18 at 19:22
  • 1
    Possible duplicate of How can I deactivate Bluetooth on system startup? – naXa Oct 25 '18 at 5:22
11

I've tested this and it's persistent across reboots.

Click the bluetooth logo between the keyboard and battery icons on the system tray. Then click the "Bluetooth ON" selection and it changes to "Bluetooth OFF":

bluetooth off.gif


After comments I discovered that Ubuntu 18.04 with Gnome interface doesn't work like Ubuntu 16.04 with Unity interface.

The solution is to edit /etc/default/tlp and find:

# Radio devices to disable on startup: bluetooth, wifi, wwan.
# Separate multiple devices with spaces.
#DEVICES_TO_DISABLE_ON_STARTUP="bluetooth wifi wwan"

Edit the last line to read:

DEVICES_TO_DISABLE_ON_STARTUP="bluetooth"
  • 2
    I'm gonna assume you really did think I haven't tried the most basic solution. When I do this, the bluetooth is back on after reboot. – Lucy C Jun 17 '18 at 22:53
  • @LucyC I just noticed from your screenshots you don't even have the bluetooth icon in systray. Furthermore you are using Gnome interface and not Unity 16.04 interface like me. Are you using Ubuntu 18.04? – WinEunuuchs2Unix Jun 17 '18 at 23:04
  • I'm running Ubuntu 18.04 LTS. My bluetooth icon can be found in the dropdown settings menu as shown here: [ibb.co/h5pmaJ] – Lucy C Jun 17 '18 at 23:09
  • @LucyC I'll reboot using Ubuntu 18.04 LTS with default Gnome interface and check it out. – WinEunuuchs2Unix Jun 17 '18 at 23:10
  • @LucyC After rebooting into Ubuntu 18.40 I was shocked to learn under the Gnome interface the setting isn't retained. On searching for a solution I found a duplicate question with an accepted answer so voted to close your question as a duplicate. So now I'll boot back into 16.04 which just works :) – WinEunuuchs2Unix Jun 17 '18 at 23:20
5

Well, I have a suggession. I think most of the people will try to make the devices to remember the state of the previous shutdown. Thus if wifi/bluetooth is turned off/on before the previous shutdown, then after rebooting, wifi/bluetooth remains off/on according the previous state.

To do this, go to the file /etc/default/tlp and search for the line

RESTORE_DEVICE_STATE_ON_STARTUP=0

This is set as "0" by default, which means that remembering the state of radio is disabled by default. To make it remember the previous state, replace "0" with "1". If you set this as "1", the lines after that will not be read by the system.

If you specifically wants to set some radio to be on or off at start up, then follow the lines

#DEVICES_TO_DISABLE_ON_STARTUP="bluetooth wifi wwan"

and

#DEVICES_TO_ENABLE_ON_STARTUP="bluetooth wifi wwan"

and remove the '#' to activate any of those line. And you can choose between bluetooth/wifi/wwan or all of them.

Do as you need.

2

I work under Xubuntu 18.04. Here is a solution that finally worked for me.

  1. First, I edited the file /etc/bluetooth/main.conf (under sudo mode enabled). At the very end of the file, I changed the line AutoEnable=true to AutoEnable=false

  2. Second, I went to the main menu, then picked Settings > Session and Startup. In the Applications autostart section I disabled Blueman applet (see line 2 in the picture below).

Blueman applet disabled in 'Session and Startup'

  1. After reboot, the Blueman applet icon is no longer visible in the system tray but if you enter rfkill list all in the terminal, you see the following:

1: phy0: Wireless LAN Soft blocked: no Hard blocked: no 2: dell-wifi: Wireless LAN Soft blocked: no Hard blocked: no 3: dell-bluetooth: Bluetooth Soft blocked: yes Hard blocked: no 4: hci0: Bluetooth Soft blocked: yes Hard blocked: no

Which means that the Bluetooth is now off. The key to the problem, it seems, is ridiculously simple. Any attempt to switch the Blueman applet on also switches on the Bluetooth no matter what happened before. So, no Blueman applet, no more Bluetooth on boot. At least, for me.

  • Worked for me on Ubuntu 18.10 - step 1 was totally enough for me (Blueman does not seem to be installed) :) – RobertG Jan 29 at 20:10
2

With ubuntu 18.04 gnome this worked for me:

sudo systemctl disable bluetooth.service

then after reboot try to check:

sudo systemctl status bluetooth.service

And if you want to enable it again:

sudo systemctl enable bluetooth.service
1

I have a workaround for your case...

I'm using Ubuntu Mate 18.04, in my case I just click on "MENU/Preferences/Startup Applications". A window called "Startup Applications Preferences" pops up. Find the entry called "Blueman Applet" and remove the tick/tag from it so that it becomes disabled (grayed out). As a result, all the applications related with Bluetooth will not load the next time(s) you boot up your system.

The annoying part is that you will have to reverse this procedure and reboot to get bluetooth back to work in case you need it.

Hope this helps JaMedSyS

1

For ubuntu 18.04. touching files like turn it off if you use blueman as a bluetooth application. For this I go to this location with a file browser executed with superuser permissions:

/usr/bin/

and I edit the file called:

"Blueman-applet"

Within this file there is written a line that says:

self.Plugins.Run(“on_manager_state_changed”, True)

You just have to change true to false and it would stay like this:

self.Plugins.Run ("on_manager_state_changed", False)
0

the rc.local way appears right to me, yet I'd do it slightly different:

sudo nano /etc/rc.local

either the file is empty - it has just been created by you - or not, edit it to look like this:

#!/bin/sh

rfkill block bluetooth

exit 0

the first and last lines are important.

0

I'm running Ubuntu 18.04.2 "bionic" with KDE (so kubuntu 18.04.2) and all I did was issue:

sudo rfkill block bluetooth

It does not enable itself after a reboot. To enable, all I do is go into bluetooth settings and tick the checkbox "Enable Bluetooth Integration".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.