After installing MAAS 2.4 on Ubuntu 18.04 LTS, I enlisted my nodes properly. When trying to commission, though, none of the commissioning goes thru due to the exact same error in two steps:

First issue: 00-maas-03-install-lldpd: Failed installing dependencies (Status 100) with error as "E: Unable to locate package lldpd"

Second issue: 99-maas-02-capture-lldp: with the log below (exit status 1)

Traceback (most recent call last):

  File "/tmp/user_data.sh.4tYV3m/scripts/commissioning/99-maas-02-capture-lldp", line 25, in <module>

    lldpd_capture(*args, **kwargs)

  File "/tmp/user_data.sh.4tYV3m/scripts/commissioning/99-maas-02-capture-lldp", line 16, in lldpd_capture

    time_ref = getmtime(reference_file)

  File "/usr/lib/python3.6/genericpath.py", line 55, in getmtime

    return os.stat(filename).st_mtime

FileNotFoundError: [Errno 2] No such file or directory: '/var/run/lldpd.socket'

MAAS box network defined as:

  version: 2
  renderer: networkd
      addresses: []
      dhcp4: n
        addresses: [,]
      addresses: []
      dhcp4: n
        search: [maas]
        addresses: [,]

eno1 is private MAAS network. enp1s0 is used for internet access via a FW.

All of the failing nodes have two NICs on them. One for AMT power control (on board NIC) with some static IP associated with them (though ifconfig reveals that it is being overridden with maas DHCP assignment) and the second NIC.

When I put the failing node in rescue mode and log in, I see that the second NIC is not even set up with DHCP. Looks like the node is still in pre-commissioned state ( as it was failed maybe).

Scratching my head on this for a while now. I am pretty new with 18.04 as well and its netplan networking.

Is it related to the network I am wondering now? Is it really related to lldpd install?

Any help on this would be greatly appreciated.


It looks like the issue was related to the netplan definition. At the end of the netplan yaml, I added this and nodes can deploy. I have another issue, but, that is for another post, hopefully I don't have to post just yet.

        - to:
          on-link: true

I hope this answer is helpful for someone else. I will wait a while until I mark this as an answer unless someone else can pitch in.


This also happens when you have your apt repos set to your MAAS or proxy, but your gateway isn't your MAAS controller.

Settings -> Network Services -> Proxy -> "Don't use a proxy" -> save

Then commission your machine again.


I was also getting this error and "apt update" was failing too. It turned out to be because squid was resolving domains to IPv6 addresses which my ISP does not support. My solution was to add:

dns_v4_first on

at the beginning of


And then restart the maas-proxy service

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.