1

I'm on ubuntu 18.04. I installed nvidia-driver-390 through my Software & Updates and it started Performance mode, which I don't need for the most of the time so I switched to Power Saving mode, it hang for a while and told me to reboot and so I did. But now I can't start nvidia-settings to turn performance mode back on, I get following errors when trying to run sudo nvidia-settings

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system

While I'm pretty sure it should start in some kind of poor-mode with limited options. Did I do something wrong or is that a bug? How do I switch between modes?

2 Answers 2

0

This is because when you are switching to power saving mode, nvidia-settings is creating a file called /etc/modprob.d/blacklist-nvidia.conf. This file should be cleared when you switch mode back to nvidia, which is not happening in 18.04.

If you wish to switch to nvidia again, you will have to manually remove this file and reboot. only switching to nvidia from nvidia-settings wont work in 18.04. There is an bug raised for this here. There are also some said fixes for this out there, but none has worked for me.

I am struggling with similar nvidia card issues on 18.04, due to some internal changes in the drivers, switch to wayland, and other things it seems like a mess on 18.04. There was chat that some of these should be fixed in 18.10, it not a very long wait, so look forward to it. :)

0

I am facing the same issue. After selecting Intel (Power Saving mode) and doing restart. I am getting same error. But I cannot /etc/modprob.d/blacklist-nvidia.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.